# Ecommerce (Course Admin Tool ) not working (Server Error)

**URL:** <https://discuss.openedx.org/t/ecommerce-course-admin-tool-not-working-server-error/6000>\
**Category:** Site Operations Help\
**Tags:** ecommerce, koa\
**Created:** [October 24, 2021, 4:34pm UTC](https://discuss.openedx.org/t/ecommerce-course-admin-tool-not-working-server-error/6000 "2021-10-24T16:34:11Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![tomg10](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/tomg10/32/1928_2.png) [@tomg10](https://discuss.openedx.org/u/tomg10)\
**Post date:** [October 24, 2021, 4:34pm UTC](https://discuss.openedx.org/t/ecommerce-course-admin-tool-not-working-server-error/6000/1 "2021-10-24T16:34:11Z")

</div>

Hello Everyone

I’m using Koa and have tried to enable Ecommerce on custom Domain  
Admin and Oscar Dashboard are working But I can not access the (Course Admin Tool)

Here How I have done all,

```auto
sudo su ecommerce -s /bin/bash
cd ~/ecommerce
source ../ecommerce_env
python manage.py makemigrations
python manage.py migrate

python manage.py create_or_update_site --site-id=1 —site-domain=https://myecommerceSubdomain.domain.com --partner-code=edX --partner-name='Open edX' —lms-url-root=https://mylmsSubdomain.domain.com —payment-processors=cybersource,paypal --backend-service-client-id=ecommerce-backend-service-key --backend-service-client-secret=ecommerce-backend-service --sso-client-id=ecommerce-sso-key --sso-client-secret=ecommerce-sso-secret —from-email:myemail —discovery_api_url=https://myDiscoverySubdomain.domain.com

```

And then on django Admin I have added this as the Redirect uris:  
[https://myecommerceSubdomain.domain.com](https://myecommerceSubdomain.domain.com)

---

<div class="post-metadata">

**Author:** ![nizar](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/nizar/32/1748_2.png) [@nizar](https://discuss.openedx.org/u/nizar)\
**Post date:** [October 25, 2021, 12:23pm UTC](https://discuss.openedx.org/t/ecommerce-course-admin-tool-not-working-server-error/6000/2 "2021-10-25T12:23:28Z")

</div>

According to @tomg10, the issue was resolved.

@tomg10 described the issue on [Slack](https://openedx.slack.com/archives/C02SNA1U4/p1635159081024600?thread_ts=1635077262.012200&cid=C02SNA1U4)…

> I think The problem was  
> That I have misspelled the Backend service Client secret

Accordingly, I’m closing this topic.

---

<div class="post-metadata">

**Author:** ![nizar](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/nizar/32/1748_2.png) [@nizar](https://discuss.openedx.org/u/nizar)\
**Post date:** [October 25, 2021, 12:23pm UTC](https://discuss.openedx.org/t/ecommerce-course-admin-tool-not-working-server-error/6000/3 "2021-10-25T12:23:34Z")

</div>


