# Getting server error in ecommerce tutor plugin

**URL:** <https://discuss.openedx.org/t/getting-server-error-in-ecommerce-tutor-plugin/13470>\
**Category:** Tutor Help\
**Tags:** api, how-to, ecommerce, devstack, tutor\
**Created:** [July 23, 2024, 9:57am UTC](https://discuss.openedx.org/t/getting-server-error-in-ecommerce-tutor-plugin/13470 "2024-07-23T09:57:00Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ronak\_Pansuriya1](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/ronak_pansuriya1/32/6909_2.png) [@Ronak\_Pansuriya1](https://discuss.openedx.org/u/Ronak_Pansuriya1)\
**Post date:** [July 23, 2024, 9:57am UTC](https://discuss.openedx.org/t/getting-server-error-in-ecommerce-tutor-plugin/13470/1 "2024-07-23T09:57:00Z")

</div>

I am getting server error in ecommerce.

I installed an e-commerce plugin. [https://github.com/overhangio/tutor-ecommerce](https://github.com/overhangio/tutor-ecommerce)

I created a new course in Studio and e-commerce. [http://ecommerce.local.edly.io/courses/](http://ecommerce.local.edly.io/courses/)

 ![image](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/a/aa070d93621b1b31c207d739d0de2b403500fe80.png)

I saw the course upgrade button in Learning MFE.

 ![image](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/9/9abfd48f3ae0353b176594d4422b7167e1cd52f3.png)

But when I click the upgrade button, it redirects to e-commerce and results in a server error.

 ![image](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/0/0008a7863fd073c3e7db5ab3518035f145f5fbc1.png)  
 ![image](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/3/373843bf927431650a1bd4f77595cf317d9ff280.png)

Does anyone have any idea about this error?? Did I miss anything? Your help would be greatly appreciated. Thank you in advance!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/e/e0015f89e879bc75925b71fd11133ab15fe98297.png) [@system](https://discuss.openedx.org/u/system)\
**Post date:** [July 23, 2024, 9:57am UTC](https://discuss.openedx.org/t/getting-server-error-in-ecommerce-tutor-plugin/13470/2 "2024-07-23T09:57:42Z")

</div>



---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/e/e0015f89e879bc75925b71fd11133ab15fe98297.png) [@system](https://discuss.openedx.org/u/system)\
**Post date:** [July 23, 2024, 10:58am UTC](https://discuss.openedx.org/t/getting-server-error-in-ecommerce-tutor-plugin/13470/3 "2024-07-23T10:58:43Z")

</div>



---

<div class="post-metadata">

**Author:** ![ghassan](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/ghassan/32/2779_2.png) [@ghassan](https://discuss.openedx.org/u/ghassan)\
**Post date:** [July 23, 2024, 2:54pm UTC](https://discuss.openedx.org/t/getting-server-error-in-ecommerce-tutor-plugin/13470/4 "2024-07-23T14:54:16Z")

</div>

It seems from the logs that it complains that there are no certficate for the course since it’s is `verifed`, I would say try eiter:  
1- create course of type `Professional Education` (which doesn’t require certfiacte) [ref](https://edx-ecommerce.readthedocs.io/en/latest/create_products/create_course_seats.html) in ecommerce after deleting the one you created of type `Verfied`  
2- Create certficate of the course

Also note there is payment MFE, that is responsbile for that view, I think after installing the ecommerce, you would have to rebuild the MFE image and restart the services for it to show up.

---

<div class="post-metadata">

**Author:** ![Ronak\_Pansuriya1](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/ronak_pansuriya1/32/6909_2.png) [@Ronak\_Pansuriya1](https://discuss.openedx.org/u/Ronak_Pansuriya1)\
**Post date:** [July 24, 2024, 10:18am UTC](https://discuss.openedx.org/t/getting-server-error-in-ecommerce-tutor-plugin/13470/5 "2024-07-24T10:18:06Z")

</div>

@ghassan Thank you for your response.

I tried with both Professional Education and Verified Mode, with the certificate enabled, but I’m encountering the same problem.

 ![Screenshot from 2024-07-24 12-14-51](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/4/454f6eec5e3ef4e256fa9b467dcd64ef39a9c438.png)

Do you have any idea about this error? Did I miss anythings?

---

<div class="post-metadata">

**Author:** ![ghassan](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/ghassan/32/2779_2.png) [@ghassan](https://discuss.openedx.org/u/ghassan)\
**Post date:** [July 24, 2024, 3:25pm UTC](https://discuss.openedx.org/t/getting-server-error-in-ecommerce-tutor-plugin/13470/6 "2024-07-24T15:25:35Z")

</div>

Have you tried rebuilding the MFE image, `tutor images build mfe`, because again that endpoint suppose to be served by payment mfe, which gets enabled after you install the ecommerce plugin but you would have to rebuild the mfe image.

---

<div class="post-metadata">

**Author:** ![Ronak\_Pansuriya1](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/ronak_pansuriya1/32/6909_2.png) [@Ronak\_Pansuriya1](https://discuss.openedx.org/u/Ronak_Pansuriya1)\
**Post date:** [July 25, 2024, 9:18am UTC](https://discuss.openedx.org/t/getting-server-error-in-ecommerce-tutor-plugin/13470/7 "2024-07-25T09:18:00Z")

</div>

Thank you @ghassan You are right. I did tutor images build mfe and it’s works.

The problem was that I tried to set it up in the Tutor Quince version, which caused many errors. After setting it up in the latest version of Tutor, it’s now working.

but now I am getting this problem.

 ![image](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/5/596fb82bcb93b3a6525f80970f6b793e8f1b9151.png)

my payment page isn’t working as expected. Do you know about this issue?
