Openedx k8s installation

I am trying to install an OpenEdx production environment on a kubernetes cluster that I have installed on three servers that I had available.
The cluster consists of a master and two workers. To perform the OpenEdx installation, I have installed tutor on the master node and tried to follow the steps in the documentation (Kubernetes deployment — Tutor documentation).
However when I run

$ tutor k8s launch

process ends with an error in the execution of a MinIO cronjob.

Job minio-job-20230413121915 is running. To view the logs from this job, run:
kubectl logs --namespace=openedx --follow $(kubectl get --namespace=openedx pods --selector=job-name=minio-job-20230413121915 -o=jsonpath=“{.items[0]}”)
Waiting for job completion…
Error: Job minio-job-20230413121915 failed. View the job logs to debug this issue.

… more info …
$ kubectl -n openedx logs minio-job-20230413121915-jv9mf
Added minio successfully. mc: Unable to make bucket minio/openedx. Put “http://minio:9000/openedx/”: dial tcp connect: connection refused mc: Unable to make bucket minio/openedxuploads. Put “http://minio:9000/openedxuploads/”: dial tcp connect: connection refused mc: Unable to make bucket minio/openedxvideos. Put “http://minio:9000/openedxvideos/”: dial tcp connect: connection refused

Hi Nacho, and welcome to this community! Maybe @gabor (our resident K8s expert) can help out.

@nachotheix Unfortunately, we are not using minio, so I cannot really help much, though @regis may already met with this issue.

What I would check with no context if minio is running and not in a crash back loop. I can imagine that the job is trying to be executed against a failed pod.

1 Like