# Problems enabling Open edX Search

**URL:** <https://discuss.openedx.org/t/problems-enabling-open-edx-search/815>\
**Category:** Site Operations Help\
**Created:** [November 8, 2019, 1:56pm UTC](https://discuss.openedx.org/t/problems-enabling-open-edx-search/815 "2019-11-08T13:56:06Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![Yago](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/yago/32/367_2.png) [@Yago](https://discuss.openedx.org/u/Yago)\
**Post date:** [November 19, 2019, 7:18am UTC](https://discuss.openedx.org/t/problems-enabling-open-edx-search/815/3 "2019-11-19T07:18:44Z")

</div>

Thank you very much for your support @joshm, now I see things more clear. It seems my problem is with the Discovery service.

- When I try to run the catalog through CLI commands as `./manage.py lms cache_programs` it gives a Server Error calling to `/api/v1/pathways/?exclude_utm=1&page=1`. I’ve notice the service depends on the value of COURSE\_CATALOG\_URL in `admin/site/site_configuration`. If I put _localhost_ it gives a generic 500 and if I put the _server name_ it throws a **Connection Error**.

- When opening `/courses/` page, there is a call to `/search/course_discovery/` that returns a JSON of empty facets: `{"facets": {"org": {"total": 0, "terms": {}, "other": 0}, "modes": {"total": 0, "terms": {}, "other": 0}, "language": {"total": 0, "terms": {}, "other": 0}}, "total": 0, "max_score": null, "took": 2, "results": []}`

The problem is that I don’t know how to test the Discovery service further than `$ sudo /edx/bin/supervisorctl status` (that shows service is RUNNING) and could not find any documentation further than [this one](https://edx-discovery.readthedocs.io/en/latest/quickstart.html) that seems to be outdated, as I cannot find the commands provided (neither in `/edx/app/edxapp` nor `/edx/app/discovery`).

Thanks for any help

Regards

> PD: `/courses/` page works like you said, switching off `FEATURES["ENABLE_COURSE_DISCOVERY"]` shows all the courses, but that is not what I am looking for ☹ And what a pity we don’t have the page shown in [edx.org](http://edx.org)…

> PD2: Finally I managed to enable course reindexing by adding the following values in `lms.env.json`:

```auto
    "COURSE_DISCOVERY_FILTERS": ["org", "language", "modes"],
    "COURSE_DISCOVERY_MEANINGS": {
            "org": {
                    "name": "Organization"
            },
            "modes": {
                    "name": "Course Type",
                    "terms": {
                            "honor": "Honor",
                            "verified": "Verified"
                            }
                    },
            "language": "en"
        },

```

---

_[View the full topic](https://discuss.openedx.org/t/problems-enabling-open-edx-search/815)._
