“Sign in with your company or school” link present but not working

I contacted Bitnami with my problem because I’m using their installer for Open edX, and they suggested I post my question here since it is related to OpenEdX itself and not to their installer. So my hope is that someone here may have some insight into the problem I’m experiencing.

I’m trying to get SAML authentication working with my institution’s Shibboleth system. I see the “Sign in with your company or school” link on the login page, but clicking it does nothing. When I use Firefox’s Web Developer Tools to inspect this link, it appears to have no event handlers associated with it. (Perhaps I’m misunderstanding what I’m seeing.) The steps I’ve taken thus far are:

  • I installed Bitnami’s OpenEdX (bitnami-edx-koa.2-0-linux-x64-installer.run) on Kubuntu 20.04 LTS
  • I used the /admin page to create a Provider Configuration (SAML IdP) entry, which is enabled and has a green check mark in its “Metadata Ready” column
  • I created a SAML Configuration entry, which is enabled (green check mark)
  • I ran the openssl command to generate saml.crt and saml.key
  • I put the .crt and .key values to the SAML Configuration (i.e., database) and I also put them into the lms.yml file (SOCIAL_AUTH_SAML_SP_PUBLIC_CERT and SOCIAL_AUTH_SAML_SP_PRIVATE_KEY, respectively)

Please let me know if any other information would be useful.

Any help would be greatly appreciated.

1 Like

I’m wondering, does anyone have an idea?

Thanks in advance.

Hi
I have the same issue did you find the solution?