# Studio Superuser Login, User Account Profiles and Indigo Theme issues with Maple/Tutor

**URL:** https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363
**Category:** Site Operations Help
**Tags:** studio, tutor
**Created:** [May 29, 2022, 4:52pm UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363 "2022-05-29T16:52:05Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![Richard\_Gehrs](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/richard_gehrs/32/3710_2.png) [@Richard\_Gehrs](https://discuss.openedx.org/u/Richard_Gehrs)
#### Post date: [May 29, 2022, 4:52pm UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/1 "2022-05-29T16:52:05Z")

</div>

I have been attempting to get my first install of Open edX running for 2 weeks though still facing THREE ISSUES as outlined separately below.

I have reviewed and searched most every manual and post I could find relating to this release of Maple/Tutor plus have watched numerous videos… I am stumped, so I finally am reaching out to this forum for help.

**NOTE** : I am using [Overhand.io](http://Overhand.io)’s Tutor v13.1.0 on AWS with a EC2 t3a.large instance. This version of Tutor is what AWS Marketplace presently installs.  
**NOTE** : I do have my HTTPS certificate installed and DNS set to “[mydomainname.com](http://mydomainname.com)” and “\*.mydomainname.com”. FYI: I do NOT have a DNS CNAME set for “[studio.mydomainname.com](http://studio.mydomainname.com)”.  
**NOTE** : I did get email/SMTP configured and working.  
**NOTE:** I did install the demo class and it’s functions as expected.  
**NOTE** : Below is my PLUGIN configuration

> plugins list

- android==13.0.0 (disabled)
- discovery==13.0.0 (disabled)
- ecommerce==13.0.0 (disabled)
- forum==13.0.0 (disabled)
- license==13.0.0 (disabled)
- mfe==13.0.1
- minio==13.0.0 (disabled)
- notes==13.0.0 (disabled)
- richie==13.0.0 (disabled)
- webui==13.0.0
- xqueue==13.0.0 (disabled)

**ISSUE ONE:**  
I cannot log into Studio… takes me to the LMS to sign in but then, after entering the superuser credentials (user name = admin), I receive the error message Error: invalid request Mismatching redirect URI. Appears to log me into the LMS since my superuser name appears.

 ![STUDIO SIGN IN ERROR](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/5/57dd1f1525b022faa636450d43160c92ee8ab5ec.png)

**ISSUE TWO:**  
From the LMS screen, I can’t VIEW/OPEN the logged in users ACCOUNT nor their PROFILE. I receive this error message “There has been a 500 error on the Praxis Focused Learning Experience servers.”

 ![ERROR WHEN OPENING ACCOUNT SETTINGS UNDER USERS NAME DROPDOWN There has been a 500 error on the Praxis Focused Learning Experience servers](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/5/5e8bcddcd55bfc8997c10a198ff24f5e7cb365b7.png)

**ISSUE THREE:**  
When loading/installing the INDIGO theme I receive the following _error messages_ thus I am not successful in the installation of a different theme.

```auto
Creating tutor_local_lms-job_run … done

Loading settings lms.envs.tutor.production

2022-05-28 15:33:56,696 WARNING 9 [py.warnings] [user None] [ip None] warnings.py:109 - /openedx/venv/lib/python3.8/site-packages/boto/plugin.py:40: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module’s documentation for alternative uses import imp

2022-05-28 15:33:56,773 WARNING 9 [py.warnings] [user None] [ip None] warnings.py:109 - /openedx/venv/lib/python3.8/site-packages/botocore/vendored/requests/packages/urllib3/_collections.py:1: DeprecationWarning: Using or importing the ABCs from ‘collections’ instead of from ‘collections.abc’ is deprecated since Python 3.3, and in 3.10 it will stop working from collections import Mapping, MutableMapping

2022-05-28 15:33:58,224 WARNING 9 [py.warnings] [user None] [ip None] warnings.py:109 - /openedx/edx-platform/openedx/core/lib/api/view_utils.py:5: DeprecationWarning: Using or importing the ABCs from ‘collections’ instead of from ‘collections.abc’ is deprecated since Python 3.3, and in 3.10 it will stop working from collections import Sequence # lint-amnesty, pylint: disable=no-name-in-module, deprecated-class

2022-05-28 15:33:58,560 WARNING 9 [py.warnings] [user None] [ip None] warnings.py:109 - /openedx/edx-platform/openedx/core/types/admin.py:49: DeprecationWarning: Django 3.2+ available: the _admin_display method and the AdminMethodclass should be removed from openedx.core.types warnings.warn(

Assigning theme indigo to www.PraxFLEX.com…
Assigning theme indigo to www.PraxFLEX.com:8000…
Assigning theme indigo to www.Studio.PraxFLEX.com…
Assigning theme indigo to www.Studio.PraxFLEX.com:8001…
Assigning theme indigo to preview.www.PraxFLEX.com…
Assigning theme indigo to preview.www.PraxFLEX.com:8000…

```

\*\*Any direction for where to read, what to look for or things to try will be MUST APPRECIATED. I am new at Open edX and such installations so the more basic/explanatory the instructions the better. \*\*  
**Thanking you in advance, Richard**

---

<div class="post-metadata">

### Author: ![regis](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/regis/32/2640_2.png) [@regis](https://discuss.openedx.org/u/regis)
#### Post date: [May 30, 2022, 12:36pm UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/2 "2022-05-30T12:36:41Z")

</div>

Hi @Richard_Gehrs,

> [@Richard\_Gehrs](#):
>
> **ISSUE ONE:**  
> I cannot log into Studio

This issue was actually fixed only very recently: [First authentication in Studio raises a 500 error: `social_core.exceptions.AuthStateMissing: Session value state missing.` · Issue #114 · openedx/wg-build-test-release · GitHub](https://github.com/openedx/build-test-release-wg/issues/114#issuecomment-1128686358)  
The fix will be included in v13.2.3, which will be published in a few minutes.  
I’m sorry that the AMI is based on an older release; Amazon makes publishing new versions on the marketplace quite difficult.

> [@Richard\_Gehrs](#):
>
> **ISSUE TWO:**  
> From the LMS screen, I can’t VIEW/OPEN the logged in users ACCOUNT nor their PROFILE. I receive this error message “There has been a 500 error on the Praxis Focused Learning Experience servers.”

I’m pretty sure that this is because your LMS/CMS hosts include capital letters, which is an interesting issue that I never faced before. Can you please try to use only lowercase letters during `tutor local quickstart`? This might resolve issue 3 as well.

---

<div class="post-metadata">

### Author: ![Richard\_Gehrs](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/richard_gehrs/32/3710_2.png) [@Richard\_Gehrs](https://discuss.openedx.org/u/Richard_Gehrs)
#### Post date: [May 30, 2022, 4:24pm UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/3 "2022-05-30T16:24:13Z")

</div>

Regis…. Much thanks for the advice to follow.

I check on AWS for the updated Tutor though it remains to say it’s Ver v13.1.0 . I am NOT trying to rush you or your team, just wanted to see if this is how I upgrade or is there a different link to obtain the updated release.

 ![](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/b/bc8592cf7b6d1e71982123635e65d02c07a9bffb.png)

Also I have new dilemma.

After reading your initial reply and using the Command Line I received an error message of “ERROR 28 no space left on device”. I increased my storage from 25GIB to 50GIB and restarted the instance. Now I am getting the error message of “Error: Invalid configuration: expected dict, got \<class ‘NoneType’\>“

Any thoughts???

![](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/0/06fdd9b1945baf92e180d37b2e0c6be5de81e890.png)

Thanks again Regis…. Have a great day, Richard G

---

<div class="post-metadata">

### Author: ![regis](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/regis/32/2640_2.png) [@regis](https://discuss.openedx.org/u/regis)
#### Post date: [May 30, 2022, 8:16pm UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/4 "2022-05-30T20:16:29Z")

</div>

I suggest you upgrade tutor on your server; connect with ssh, then login as the “tutor” user and execute the upgrade script: [https://overhang.io/tutor/ami/upgrade.sh](https://overhang.io/tutor/ami/upgrade.sh)

```auto
ssh ubuntu@3.227.249.31
sudo su tutor
curl https://overhang.io/tutor/ami/upgrade.sh | bash

```

---

<div class="post-metadata">

### Author: ![Richard\_Gehrs](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/richard_gehrs/32/3710_2.png) [@Richard\_Gehrs](https://discuss.openedx.org/u/Richard_Gehrs)
#### Post date: [June 1, 2022, 7:53pm UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/5 "2022-06-01T19:53:12Z")

</div>

Regis, I reinstall my Open EDx on AWS using the Tutor version 13.0.2. With your expert guidance, all of my issues **but one** have been resolved. Thanks!

I remain unable to VIEW/OPEN the logged in users ACCOUNT or their PROFILE from the LMS. The error message I receive has changed from ERROR 500 to " _This site can’t be reached Check if there is a typo in…_" and is shown in an attachment to this message.

 ![PROFILE ERROE](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/1/1060c9cb4e2e199f23a5650f576cca26b2f3dec8.png)

Any thoughts? Richard G

---

<div class="post-metadata">

### Author: ![regis](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/regis/32/2640_2.png) [@regis](https://discuss.openedx.org/u/regis)
#### Post date: [June 7, 2022, 9:09am UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/6 "2022-06-07T09:09:38Z")

</div>

The “[apps.www.praxflex.com](http://apps.www.praxflex.com)” domain does not resolve: [DNS Lookup - Check DNS Records](https://dnschecker.org/all-dns-records-of-domain.php?query=apps.www.praxflex.com&rtype=ALL&dns=google)

The tutor-mfe plugin requires the domain name that corresponds to the `MFE_HOST` tutor setting to be properly defined. In your case I suggest you run `tutor config save --set MFE_HOST=apps.praxflex.com` to run the MFE apps on this domain.

@arbrandes this question made me realize that at no point do we mention the configuration of DNS records in the tutor-mfe README: [GitHub - overhangio/tutor-mfe](https://github.com/overhangio/tutor-mfe/) Could you please add a mention there?

---

<div class="post-metadata">

### Author: ![arbrandes](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/arbrandes/32/158_2.png) [@arbrandes](https://discuss.openedx.org/u/arbrandes)
#### Post date: [June 7, 2022, 3:49pm UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/7 "2022-06-07T15:49:32Z")

</div>

> [@regis](#):
>
> at no point do we mention the configuration of DNS records in the tutor-mfe README: [GitHub - overhangio/tutor-mfe](https://github.com/overhangio/tutor-mfe/) Could you please add a mention there?

Certainly! Adding it to my TODO.

---

<div class="post-metadata">

### Author: ![Richard\_Gehrs](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/richard_gehrs/32/3710_2.png) [@Richard\_Gehrs](https://discuss.openedx.org/u/Richard_Gehrs)
#### Post date: [June 8, 2022, 12:10am UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/8 "2022-06-08T00:10:36Z")

</div>

Regis, As always, I appreciate your help, patients and knowledge.

I issued the commands via SSH as you instructed and replied to all the “quickstart” type questions BUT now, since this Tutor update ran, I cannot access the web user interface at [http://yourinstanceaddress:3737](http://yourinstanceaddress:3737). That address worked fine prior to the Tutor version update that I did. I still am able to access both LMS and CMS and they are secure. I am assuming the LMS and CMS is running the new version of Tutor but without this access I can’t check. Any thoughts??? Richard G

 ![](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/d/db2c4f3777ce1e6159e43bbd8b70bd4f7e13d273.png)

Also **one** more question…… What command do I execute via SSH to perfume the requested/suggested “System Restart” Richard G

![](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/7/7a49b477e43889e7949e804f781266f16cf06d8a.png)

---

<div class="post-metadata">

### Author: ![regis](https://sea2.discourse-cdn.com/flex020/user_avatar/discuss.openedx.org/regis/32/2640_2.png) [@regis](https://discuss.openedx.org/u/regis)
#### Post date: [June 27, 2022, 9:24am UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/9 "2022-06-27T09:24:40Z")

</div>

Sorry about the delay @Richard_Gehrs… I see that the 3737 web interface is still not working for you. You should ssh to the server and login as the tutor user to view the errors:

```auto
ssh ubuntu@yourserverip
sudo su tutor

```

Then print here the output of the following commands:

```auto
# Display available disk space
df -lh
# Print output from webui service
# (you might have to run with sudo)
journalctl -u tutor-webui
# Print output from tutor
tutor local logs --tail=100
# Attempt to quickstart
tutor local quickstart

```

> [@Richard\_Gehrs](#):
>
> Also **one** more question…… What command do I execute via SSH to perfume the requested/suggested “System Restart” Richard G

```auto
sudo reboot

```

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/flex020/uploads/openedx/original/2X/e/e0015f89e879bc75925b71fd11133ab15fe98297.png) [@system](https://discuss.openedx.org/u/system)
#### Post date: [September 25, 2022, 9:24am UTC](https://discuss.openedx.org/t/studio-superuser-login-user-account-profiles-and-indigo-theme-issues-with-maple-tutor/7363/10 "2022-09-25T09:24:52Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
