Unable to install ficus due to python2.7 deprecation?

Hello! I’m trying to install openEdx ficus.master according to the following instructions:
https://openedx.atlassian.net/wiki/spaces/OpenOPS/pages/146440579/Native+Open+edX+platform+Ubuntu+16.04+64+bit+Installation

But then I try to install ansible I get an error:

wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/ansible-bootstrap.sh -O - | sudo bash

... a lot of logs omitted ...

Traceback (most recent call last):
  File "util/balancecontainers.py", line 7, in <module>
    from six.moves import range
ImportError: No module named six.moves
pip install -qr pre-requirements.txt --exists-action w
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
pip install -qr requirements.txt --exists-action w
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
ERROR: Package 'setuptools' requires a different Python: 2.7.12 not in '>=3.5'
WARNING: You are using pip version 19.3.1; however, version 20.0.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Makefile:20: recipe for target 'requirements' failed
make: *** [requirements] Error 1
root@vmi274432:~# python -V
Python 2.7.12

Package ‘setuptools’ requires a different Python: 2.7.12 not in ‘>=3.5’. I need that version because I need to migrate openEDX instance to a new server and save all the data. (supertask: Release update (ficus ↝ ironwood))

I could install ficus.master before with the instructions above, but now it throws an error. Any ideas?

Probably there are unpinned requirements, and ficus is pulling in versions of libraries that are too new. edX doesn’t support older versions like Ficus. Maybe someone else has fixes?