Adding analytics insight on native hawthorn fails with recipe for target 'migrate' failed

Dear All,

I would like to please suggest one thing. I already install open-edx native with a hawthorne version. I want to add analytics insight service on this machine. How can I add this service? I try to install this service, but I’m facing the error again and again. Please suggest for this service. Thanks.

Regards,
Ye Pyae Aung

1 Like

Hi, the screenshot is not much visible in the whole, can you post the log in pastebin and link it here ?

Also can you add the relevant portion of the error inside the post, not the whole log, just the relevant bits would do ? That way people will be able to search it easily in future, and it also makes it easy for people to help you as well.

1 Like

Hi, chintan,

Thanks for your suggesion. Please check my error as below link.

https://pastebin.com/DKFtWMSt?fbclid=IwAR0Chhs-fxTtTctLT6lvx9ysbPcczMDfK3CWoPTna9SwtHfLsyzIRfc0ky8

Hi, Chintan,

Please help me. I have been tried to get this service on last three months ago. Thanks.

Regards,

Hey,

Try to run migrate command from the environment or from the path, that’ll give you correct error, also if it works, you can skip this task.

Beyond that I don’t know much. I always setup insights in a different machine.

1 Like

hi @Yepyae

Your error trace says that while performing migration task it is failing, the reason is Access denied for user ‘migrate’@‘localhost’ to your db.

Grant permission to migrate user and you are good to go.

From your error trace:

“django.db.utils.OperationalError: (1045, “Access denied for user ‘migrate’@‘localhost’ (using password: YES)”)”,

1 Like

Hi @jramnai

I saw this error. But where can I change the permission? I run the command “ansible-playbook -i localhost, -c local analytics_single.yml --extra-vars “INSIGHTS_LMS_BASE=$LMS_HOSTNAME INSIGHTS_BASE_URL=$INSIGHTS_HOSTNAME” -vvv” Please help me to solve this. Thanks

You need to give permission in MySQL to that user for db. So, open your MySQL shell and grant privileges to that user.

For permission you can check it here.

1 Like

Hi @jramnai, I already give permission in MYSQL to that user for DB. But there is the same error again. Please let me know for an edx analytics insights installation. Can I install analytics insight service on native installation? Could you provide me a document? Thanks.

Hi,

Can you check permission after you get the error?

I doubt that when you start installation your changes are reverted.

And other than this I don’t have much idea about this.

1 Like