Anonymous access with Tutor and the learning MFE

Let’s say I have a course for which I granted anonymous access as per Public Course Content: in Ironwood – Open edX

For example:
which is the course outline when the user is authenticated

How do I access the course outline through Tutor when the user is unauthenticated? has a course using that feature
Course | edX
but I wonder if my inability to access the outline through Tutor is a side effect of the MFE routing differences between Tutor and

Any ideas or suggestions?

I have tried to that before and it worked for me following this guide: 4.12. Enabling Public Course Content — Installing, Configuring, and Running the Open edX Platform documentation

And Here is an example for course that you should be able to view the outline when being unauthenticated:

I am running Nutmeg/master using tutor on the demo site.

Thanks @ghassan

Yes, it does seems to work with the link to the course you gave me.
Something must be wrong on my own nutmeg server.

I was able to make it work with a brand new course, but it doesn’t work for a course that I imported. That’s strange. I have a few things to investigate now. Thanks again @ghassan

Take a look at these notes for nutmeg. it might be relaitve, I am not entrily sure.

  • The Dates Tab has been added as a default static tab on all courses, meaning it is stored as part of the course object in Mongo. Previously it was inserted as a dynamic tab at runtime. All new courses will automatically include the Dates Tab. In order to properly have the Dates Tab show up for all your existing courses, a backfill course tabs management command has been created. Run this command on your instance to properly update your default tabs on all of your existing courses. @Dillon Dumesnil (Deactivated)
    • To run the command, run ./ cms backfill_course_tabs or python cms backfill_course_tabs from your shell.
  • An internal performance improvement called “learning sequences” has been opt-in for a few releases, but is now always-on for Nutmeg. If you have any courses that have not been re-published on Koa or later, run the simulate_publish cms django command on your courses before upgrading, to populate the learning sequence data. @ Michael Terry (Deactivated)

Thanks again @ghassan

I had already seen those and ran the backfill commands previously.

I’ll take another good look at it when Nutmeg is officially released next month. I will then be able to run again the full sequence of upgrading a copy of our production systems from Koa Native to Koa Tutor and then Lilac Tutor, Maple Tutor and Nutmeg Tutor. Right now, I am doing manually some of the migrations that will be part of tutor local upgrade --from=maple very soon.

And yes there are a couple of steps to do very carefully in between the different releases with regard to persistent grades, learning sequences and course tabs management like you just pointed out. There might be others.

Right now, I am satisfied that I have a test system that survived the upgrades from Koa Native to Nutmeg Tutor. We will be ready to upgrade our production system later this summer or in early autumn. Definitely before Olive is released in December.

@sambapete just curious if you ever got it working with Nutmeg and an existing course?

Also, @ghassan, it seems like you are experiencing the same Error I am with on your site Course | zaatlearn

“There was an error loading this course.”

1 Like

I have replied to other thread,
The link to the course is old and deleted, the new course I have issue with is Course | zaatlearn
I can as anonymous user see course outlines but not the actual units, then I would see same error you reported Anonymous Course Access in Nutmeg - #5 by ghassan

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.