Broken Koa.master Native installation

Recently our team has tried to install koa.master (Native) a few times on different systems, and all installations fail on playbook:
== cmd ====
[‘make’, ‘production-requirements’]
with the following error:


Full installation log is available here:
Can you please look into this? @nedbat

1 Like

This seems to be the relevant part of the log, but I don’t know what would cause that failure:

    ERROR: Command errored out with exit status 1:
     command: /edx/app/ecommerce/venvs/ecommerce/bin/python3.8 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-hcu3at8d/django-solo/'"'"'; __file__='"'"'/tmp/pip-install-hcu3at8d/django-solo/'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-install-hcu3at8d/django-solo/pip-egg-info
         cwd: /tmp/pip-install-hcu3at8d/django-solo/
    Complete output (26 lines):
    running egg_info
    creating /tmp/pip-install-hcu3at8d/django-solo/pip-egg-info/django_solo.egg-info
    writing /tmp/pip-install-hcu3at8d/django-solo/pip-egg-info/django_solo.egg-info/PKG-INFO
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-hcu3at8d/django-solo/", line 6, in <module>
      File "/edx/app/ecommerce/venvs/ecommerce/lib/python3.8/site-packages/setuptools/", line 153, in setup
        return distutils.core.setup(**attrs)
      File "/usr/lib/python3.8/distutils/", line 148, in setup
      File "/usr/lib/python3.8/distutils/", line 966, in run_commands
      File "/usr/lib/python3.8/distutils/", line 985, in run_command
      File "/edx/app/ecommerce/venvs/ecommerce/lib/python3.8/site-packages/setuptools/command/", line 292, in run
        writer(self,, os.path.join(self.egg_info,
      File "/edx/app/ecommerce/venvs/ecommerce/lib/python3.8/site-packages/setuptools/command/", line 656, in write_pkg_info
      File "/usr/lib/python3.8/distutils/", line 1117, in write_pkg_info
      File "/edx/app/ecommerce/venvs/ecommerce/lib/python3.8/site-packages/setuptools/", line 167, in write_pkg_file
        write_field('Summary', single_line(self.get_description()))
      File "/edx/app/ecommerce/venvs/ecommerce/lib/python3.8/site-packages/setuptools/", line 151, in single_line
        raise ValueError('Newlines are not allowed')
    ValueError: Newlines are not allowed
ERROR: Command errored out with exit status 1: python egg_info Check the logs for full command output.
WARNING: You are using pip version 20.0.2; however, version 21.3.1 is available.
You should consider upgrading via the '/edx/app/ecommerce/venvs/ecommerce/bin/python3.8 -m pip install --upgrade pip' command.
make: *** [Makefile:50: production-requirements] Error 1

Installing django-solo into a Python3.8 environment works just fine.

Just tried to do a fresh install myself and indeed it failed with the same error as above.
I hope edX team will have a chance to fix this installation. Thank you in advance

To clarify the support policy: Only the latest Open edX release has been officially supported. Right now, that’s Lilac. Certainly if someone finds a fix for Koa, the build-test-release working group will consider merging it.

Even I got the same issue, fresh installation was done again stuck at same issue in two servers. posted here KOA installation error.
Any clue on this ?

“Installing django-solo into a Python3.8 environment works just fine.” Problem was not fixed with this.

Issue was resolved for me.
After activating ecommerce virtual ENV with the below commands.

  1. cd /edx/app/ecommerce/ecommerce
  2. source …/venvs/ecommerce/bin/activate
    Run “sudo make requirements”.

@divya Thank you for your reply. We’ve also managed to complete the installation after your directions. Much appreciated!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.