Bug in Build images all in Tutor with Nutmeg MFE

I am encountering a bug in Nutmeg version while running a command tutor images build all and tutor images build all–no-cache

I think the 137 error code is realted to insufficient resources.
Are you sure that you have enough Disk space and RAM?

@ghassan Thanks alot for your reply.

Dang, I gave 6.8 GB of ram to my “docker desktop” machine, but that wasn’t enough. The “137 error code” was gone after giving it 8 GB.

Hi @MaartenGH ,
What I can suggest please first reboot your system and then try again and for safety purpose create a swap memory

Yeah thanks. The problem was solved by throwing more memory at it. I posted partly to complain and partly to share my solution :wink:

I think maybe for low-memory systems it would be good if the MFE container didn’t try to build all the MFEs simultaneously, but for me the immediate problem has been solved.

This could be done if I am not mistaken by disabling Docker buildkit, I think its should be disabled by default. To check if its enabled cat /etc/docker/daemon.json. You would get something like: { "features": { "buildkit": true } } ref