Change Database to RDS and DocumentDB

Hello people! How are you?

I need help with an issue, I hope you can help me.
I worked with the hawtorn version of openedX and to make a change to the database entry I remember just having to make a change to the cms.auth.json and lms.auth.json files
However, I tried to create a juniper version and make this same change, but the application insists on searching the databases at localhost even changing the entry in these files.
Can you tell if something has changed in this version? Or am I missing an important step?

Thank you for your help!

Juniper no longer uses the cms.auth.json and lms.auth.json (or cms.env.json or lms.env.json).

The values are now in /edx/etc/studio.yml and /edx/etc/lms.yml.

You might be interested by this post

1 Like

Nice! It’s working!!! I love this forum. You help too much!

Thank you!

1 Like

@scarbacks take a look at the Juniper Upgrade Instructions which contains many other important points to take into account during migration to Juniper.


I’ll, @idegtiarov! Thanks a lot! =)