Error: invalid_request Mismatching redirect URI

This error surfaces from the Studio sign-in button on a vanilla installation of tutor-Maple running on Kubernetes. it’s resolved easily enough, by modifying the redirect uris in Django admin, in /admin/oauth2_provider/application/.

Question: is there a Django setting that i can add via tutor during deployment to proactively force the uri protocol to be https rather than http?


Probably HTTPS: on could help ?

Thanks @chintan . Kubernetes complicates the use OF ENABLE_HTTPS , so unfortunately resolving this problem is more complicated than setting this value on or off.

I resolved the problem by creating this plugin: tutor-contrib-k8s-deploy-tasks that reconfigures the subset of oauth clients – cms, discovery, ecommerce, and credentials – that are affected by this problem in Kubernetes.