Error while installing open edx using tutor

I have installed Docker in Ubuntu 22. 22.04.2 LTS using the command sudo apt-get install docker docker-compose.

I tried installing Tutor first using the command pip install “tutor[full]” which Successfully installed `appdirs-1.4.4 cachetools-5.3.1 click-repl-0.3.0 google-auth-2.21.0 jinja2-3.1.2 kubernetes-26.1.0 mypy-1.4.1 mypy-extensions-1.0.0 prompt-toolkit-3.0.38 pyasn1-0.5.0 pyasn1-modules-0.3.0 pycryptodome-3.18.0 pyyaml-6.0 requests-oauthlib-1.3.1 rsa-4.9 tomli-2.0.1 tutor-16.0.2 tutor-android-16.0.0 tutor-discovery-16.0.0 tutor-ecommerce-16.0.0 tutor-forum-16.0.0 tutor-license-16.0.0 tutor-mfe-16.0.0 tutor-minio-16.0.1 tutor-notes-16.0.0 tutor-webui-16.0.0 tutor-xqueue-16.0.0 typing-extensions-4.6.3 wcwidth-0.2.6

However, when I tried the command tutor --version It showed the message

Command 'tutor' not found, did you mean:
  command 'totor' from snap totor (0.2)
See 'snap info <snapname>' for additional versions.

So, I tried

sudo curl -L "$(uname -s)_$(uname -m)" -o /usr/local/bin/tutor
sudo chmod 0755 /usr/local/bin/tutor

This seems to have worked as tutor --version showed tutor, version 16.0.2. Unfortunately,
I wasn’t prompted with whether I want to deploy or not but rather it asked for the website domain name and so forth

        Interactive platform configuration
Your website domain name for students (LMS) [] 
Your website domain name for teachers (CMS) [] 
Your platform name/title [My Open edX] 
Your public contact email address [] 
The default language code for the platform [en] 
Activate SSL/TLS certificates for HTTPS access? Important note: this will NOT work in a development environment. [y/N] n
Configuration saved to /home/tanvir/.local/share/tutor/config.yml
Environment generated in /home/tanvir/.local/share/tutor/env
        Building Docker images
No image to build
        Stopping any existing platform
docker compose -f /home/tanvir/.local/share/tutor/env/local/docker-compose.yml -f /home/tanvir/.local/share/tutor/env/local/ --project-name tutor_local stop
unknown shorthand flag: 'f' in -f
See 'docker --help'.

Usage:  docker [OPTIONS] COMMAND

A self-sufficient runtime for containers

      --config string      Location of client config files (default
  -c, --context string     Name of the context to use to connect to the
                           daemon (overrides DOCKER_HOST env var and
                           default context set with "docker context use")
  -D, --debug              Enable debug mode
  -H, --host list          Daemon socket(s) to connect to
  -l, --log-level string   Set the logging level
                           (default "info")
      --tls                Use TLS; implied by --tlsverify
      --tlscacert string   Trust certs signed only by this CA (default
      --tlscert string     Path to TLS certificate file (default
      --tlskey string      Path to TLS key file (default
      --tlsverify          Use TLS and verify the remote
  -v, --version            Print version information and quit

Management Commands:
  builder     Manage builds
  config      Manage Docker configs
  container   Manage containers
  context     Manage contexts
  image       Manage images
  manifest    Manage Docker image manifests and manifest lists
  network     Manage networks
  node        Manage Swarm nodes
  plugin      Manage plugins
  secret      Manage Docker secrets
  service     Manage services
  stack       Manage Docker stacks
  swarm       Manage Swarm
  system      Manage Docker
  trust       Manage trust on Docker images
  volume      Manage volumes

  attach      Attach local standard input, output, and error streams to a running container
  build       Build an image from a Dockerfile
  commit      Create a new image from a container's changes
  cp          Copy files/folders between a container and the local filesystem
  create      Create a new container
  diff        Inspect changes to files or directories on a container's filesystem
  events      Get real time events from the server
  exec        Run a command in a running container
  export      Export a container's filesystem as a tar archive
  history     Show the history of an image
  images      List images
  import      Import the contents from a tarball to create a filesystem image
  info        Display system-wide information
  inspect     Return low-level information on Docker objects
  kill        Kill one or more running containers
  load        Load an image from a tar archive or STDIN
  login       Log in to a Docker registry
  logout      Log out from a Docker registry
  logs        Fetch the logs of a container
  pause       Pause all processes within one or more containers
  port        List port mappings or a specific mapping for the container
  ps          List containers
  pull        Pull an image or a repository from a registry
  push        Push an image or a repository to a registry
  rename      Rename a container
  restart     Restart one or more containers
  rm          Remove one or more containers
  rmi         Remove one or more images
  run         Run a command in a new container
  save        Save one or more images to a tar archive (streamed to STDOUT by default)
  search      Search the Docker Hub for images
  start       Start one or more stopped containers
  stats       Display a live stream of container(s) resource usage statistics
  stop        Stop one or more running containers
  tag         Create a tag TARGET_IMAGE that refers to SOURCE_IMAGE
  top         Display the running processes of a container
  unpause     Unpause all processes within one or more containers
  update      Update configuration of one or more containers
  version     Show the Docker version information
  wait        Block until one or more containers stop, then print their exit codes

Run 'docker COMMAND --help' for more information on a command.

To get more help with docker, check out our guides at

Error: Command failed with status 125: docker compose -f /home/tanvir/.local/share/tutor/env/local/docker-compose.yml -f /home/tanvir/.local/share/tutor/env/local/ --project-name tutor_local stop

And finally ended with an error. I don’t know what to do. Any help is aprreciated

please follow this for any release u need to install tutor.

Releases · overhangio/tutor (

then just do it tutor local launch or tutor dev launch

if u are using palm release and your docker composer is old v1 so u need to upgrade for palm release u can look into it also

Install the Compose plugin | Docker Documentation

I installed tutor using the command pip install “tutor[full]==16.0.2”. It installs correctly as evident by the prompt

All services initialised.
The platform is now running and can be accessed at the following urls:

However, I I’m not able to access it in the web browser. I’m not sure what what I’m doing wrong.
P.S. when I type on the web browser it automatically turns into

I ran into the exact same issues as you with the failed status 125, which made me realize I had to update my version of docker compose to v2. This proved to be a bit of a hassle but in the end, I managed to get it working with the help of answers found here:

  1. Set up the docker repository
  2. Install the docker compose plugin using the repository
  3. Troubleshooting

Regarding not being able to access services, you could try activating the SSL/TLS certificates in the config:

First, stop tutor:

tutor local stop

Then update the config:

tutor config save --interactive

And choose Y when presented with the “Activate SSL/TLS certificates for HTTPS access?” question.

Then restart tutor:

tutor local start -d

@newbie let me know after tutor local launch hit what u did here

[v16.0.1@tvm-palm] yagnesh@DSK-DEL-00001:~/tvm-palm$ tutor local launch
        Interactive platform configuration

Are you configuring a production platform? Type 'n' if you are just testing Tutor on your local computer [y/N] N

Your website domain name for students (LMS) [] 
Your website domain name for teachers (CMS) [] 
Your platform name/title [My Open edX] 
Your public contact email address [] 
The default language code for the platform [en] 

Activate SSL/TLS certificates for HTTPS access? Important note: this will NOT work in a development environment. [y/N] N

if you use a tutor in the local system show u need to set Activate SSL/TLS certificates for HTTPS access it to N. and then try it.

@rediris please let me know are u trying to install Tutor locally or on the server

if u try to install Tutor in the local system so should change it to N as per above mention.

Good point @Yagnesh, thank you. In my case I was installing it on a remote server.

@rediris did you install the tutor successfully? or are any issues still you facing related installation?

Hi @Yagnesh thank you - I have managed to get tutor (first olive, then palm) running successfully on a remote linux host as well as locally on a mac.

However, I’m having specific trouble with using custom forks of MFEs, but I should just open up a separate issue in the forum for that.

@rediris ok, u should, but please check it first forum if anyone has the same issue and solution is also in the forum so check it first.

1 Like