How to adjust bulk message's language?

hello everyone,
Today I found that language box in course settings is set to be displayed only if MKTG is disable.
I don’t know why that would be so! could you explain if you know?

Main problem:
Although my instance is set and works in Persian, bulk messages are sending in English.
Because they use course language and all courses are initially in English.
So I have to adjust my course language. but as I enabled MKTG I can’t.

Any advice is highly valuable

Can you link us to the line in the code where that conditional is?

1 Like

Thank you very much @nedbat for your answer.
Checking main repository I found that a change was made on related lines in this PR. We are still on Hawthorn.