Image not found error when Bind-Mounting a custom mfe in tutor-mfe:nightly

Hi, I’ve been trying to bind-mount a custom MFE. I have cloned my mfe using the frontend-template-application.

Here’s the steps I followed:

tutor config save --set "MOUNTS=['path/frontend-app-myapp']"
tutor images build mfe (just for good measure)
tutor dev launch

My plugin looks like the following:

I have also tried the commands:
tutor dev start myapp
which gives me the error:

Error response from daemon: pull access denied for overhangio/openedx-myapp-dev, repository does not exist or may require 'docker login': denied: requested access to the resource is denied
tutor images build myapp-dev
Error: Image 'myapp-dev' could not be found

I have tried to do the same using one of the existing CORE_MFE_APPS in tutor-mfe. For that, I cloned the frontend-app-profile repo and bind-mounted it without adding to my plugin and this worked for me and I could have hot-reloading as well.

Can anyone let me know how I can get my custom MFE to be bind mounted as well?

Thanks in advance.


I’m facing the same issue.

I believe this is the same issue that was addressed here: fix: auto-build images in nightly by regisb · Pull Request #160 · overhangio/tutor-mfe · GitHub

It will be resolved in tutor-mfe v16.1.2, which will be released in a few minutes. You can also bypass this issue by running manually tutor images build myapp-dev.

Thank you for the response. However, I’ve tried the tutor images build myapp-dev command as well as I mentioned in my post and it gives me an error:

Error: Image 'myapp-dev' could not be found

I’ve also tried the method you mentioned in this issue by manually updating the code and disabling, uninstalling tutor-mfe and then reinstalling and enabling the plugin and it would give me the same error.

Hello @Danyal_Faheem i have just tried running my mfe over tutor nightly and its working perfectly fine, the issue might be somewhere in your setup.

Thank you for informing me. I was playing around with the setup and might have changed something I wasn’t supposed to. I think I’ll try it out on a fresh install of tutor-nightly again.

1 Like