Invalid_request The requested redirect didn't match the client settings

Hello there, after installing the insights i cannot login… i followed the docs and created everything and updated the yml file etc but when i click on the login button it redirects me to
http://127.0.0.1:8000/oauth2/authorize?scope=… always.

Then I updated the url from /edx/app/insights/edx_analytics_dashboard/analytics_dashboard/settings/base.py and the redirection works now… But i am receiving this error now:
" invalid_request The requested redirect didn’t match the client settings" after I login it redirects me to https://my_domain_name/oauth2/authorize/confirm.

I am sure that my configs are good. Anyone can help?

I’m using ironwood master.

Reason

Your settings are overridden elsewhere depending on your environment (local, devstack, production, etc)

Solution

  • If you are running open edX in devstack using docker images, then you should edit settings/devstack.py instead.
  • If you are running a native (production) open edX install, then you should edit /edx/etc/insights.yml which is included by settings/production.py

Quick explanation

each open edx service (lms, cms, analytics, insights, ecommerce, etc) have many configuration files defined in this order :
1. base.py or common.py : base configuration file which defines all default settings.
2. local.py, devstack.py, production.py, … : environment-specific configurations which override the default configuration provided in (1). depending on your environment, these files may load configurations from elsewhere, as it’s the case for lms.env.json, cms.env.json. ecommerce.yml, etc …

Hi @ARMBouhali

I’m using open edx native installation so i edit in /edx/etc/insights.yml but it not work error is still.
My configs are right.

When I rerun ansible command i got this error

ansible-playbook -i localhost, -c local analytics_single.yml --extra-vars “INSIGHTS_LMS_BASE= INSIGHTS_VERSION=open-release/ironwood.master ANALYTICS_API_VERSION=open-release/ironwood.master”

TASK [git_clone : Require a clean working tree] **********************************************************************************************************
failed: [localhost] (item={’_ansible_parsed’: True, ‘stderr_lines’: , u’changed’: True, u’end’: u’2020-03-14 14:34:00.235124’, ‘_ansible_no_log’: False, u’stdout’: u’ M analytics_dashboard/settings/base.py\n M package-lock.json’, ‘_ansible_item_result’: True, u’rc’: 0, u’start’: u’2020-03-14 14:34:00.228059’, u’cmd’: u’test ! -e “/edx/app/insights/edx_analytics_dashboard” || git -C “/edx/app/insights/edx_analytics_dashboard” status --porcelain --untracked-files=no’, ‘item’: u’/edx/app/insights/edx_analytics_dashboard’, u’delta’: u’0:00:00.007065’, u’invocation’: {u’module_args’: {u’creates’: None, u’executable’: None, u’_uses_shell’: True, u’_raw_params’: u’test ! -e “/edx/app/insights/edx_analytics_dashboard” || git -C “/edx/app/insights/edx_analytics_dashboard” status --porcelain --untracked-files=no’, u’removes’: None, u’warn’: True, u’chdir’: None}}, ‘stdout_lines’: [u’ M analytics_dashboard/settings/base.py’, u’ M package-lock.json’], u’stderr’: u’’}) => {“failed”: true, “item”: {“changed”: true, “cmd”: “test ! -e “/edx/app/insights/edx_analytics_dashboard” || git -C “/edx/app/insights/edx_analytics_dashboard” status --porcelain --untracked-files=no”, “delta”: “0:00:00.007065”, “end”: “2020-03-14 14:34:00.235124”, “invocation”: {“module_args”: {"_raw_params": “test ! -e “/edx/app/insights/edx_analytics_dashboard” || git -C “/edx/app/insights/edx_analytics_dashboard” status --porcelain --untracked-files=no”, “_uses_shell”: true, “chdir”: null, “creates”: null, “executable”: null, “removes”: null, “warn”: true}}, “item”: “/edx/app/insights/edx_analytics_dashboard”, “rc”: 0, “start”: “2020-03-14 14:34:00.228059”, “stderr”: “”, “stderr_lines”: , “stdout”: " M analytics_dashboard/settings/base.py\n M package-lock.json", “stdout_lines”: [" M analytics_dashboard/settings/base.py", " M package-lock.json"]}, “msg”: “There are modified files in /edx/app/insights/edx_analytics_dashboard: M analytics_dashboard/settings/base.py\n M package-lock.json”}
to retry, use: --limit @/root/configuration/playbooks/analytics_single.retry

PLAY RECAP **********************************************************************************************************
localhost : ok=192 changed=39 unreachable=0 failed=1

plz help :cry: