Lilac 2 Installation Failed at "TASK [mysql : add the mysql signing key]"

Hello Everyone,

I’m trying to install lilac.2 but I get this errors.

TASK [mysql : Remove experimental version of mysql] ****************************
[DEPRECATION WARNING]: Invoking "apt" only once while using a loop via 
squash_actions is deprecated. Instead of using a loop to supply multiple items 
and specifying `name: "{{ item }}"`, please use `name: ['mysql-server-5.6', 
'mysql-server']` and remove the loop. This feature will be removed in version 
2.11. Deprecation warnings can be disabled by setting 
deprecation_warnings=False in ansible.cfg.
skipping: [localhost] => (item=[]) 

TASK [mysql : Install mysql dependencies] **************************************
ok: [localhost]

TASK [mysql : Install mysql] ***************************************************
skipping: [localhost]

TASK [mysql : Set default character sets and collations] ***********************
skipping: [localhost]

TASK [mysql : add the mysql signing key] ***************************************
fatal: [localhost]: FAILED! => {"changed": false, "id": "8C718D3B5072E1F5", "msg": "key does not seem to have been added"}

and

Decoded error:
== Unknown keys ======================
id: '8C718D3B5072E1F5'                                                              
== msg ===========================
key does not seem to have been added

I tried running this but it didn’t work.

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 8C718D3B5072E1F5

I think the GPG Key has expired.

What can I do? please help.

Try this one (3A79BD29), I got it from the MySQL site here:
https://dev.mysql.com/doc/mysql-apt-repo-quick-guide/en/#apt-repo-install-components

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3A79BD29

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3A79BD29
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
Executing: /tmp/apt-key-gpghome.sgWkPgJ82G/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 3A79BD29
gpg: key 467B942D3A79BD29: "MySQL Release Engineering <mysql-build@oss.oracle.com>" not changed
gpg: Total number processed: 1
4 Likes

Unfortunately it didn’t. How do I remove an expired gpg key?

pub   dsa1024 2003-02-03 [SCA] [expired: 2022-02-16]
      A4A9 4068 76FC BD3C 4567  70C8 8C71 8D3B 5072 E1F5
uid           [ expired] MySQL Release Engineering <mysql-build@oss.oracle.com>

Or how can i change the value that looks like here?

Check section 2 in this link: How To Delete A Repository And GPG Key In Ubuntu - OSTechNix to delete de old gpg key.
To override the value of MYSQL_APT_KEY, you can pass extra vars when running playbooks: Using Variables — Ansible Documentation.

2 Likes

You can change MYSQL_APT_KEY and MYSQL_APT_KEYSERVER

MYSQL_APT_KEY: “3A79BD29”
MYSQL_APT_KEYSERVER: “pgp.mit.edu

3 Likes

Hello again, firstly many thanks for your replies. I changed the line from MYSQL_APT_KEY: "8C718D3B5072E1F5" to MYSQL_APT_KEY: "467B942D3A79BD29" in the /var/tmp/configuration/playbooks/roles/mysql/defaults/main.yml file and problem solved. :tada: :tada:

1 Like