Palm version 1 has no support for timed exams

Hello I’m using palm version 1 with tutor(version 16.0.2) and has mfe version 16.0.0. edx_proctoring==4.15.0.
When i click on demo view course i’m getting this error
Axios Error (Response): 0 http://localhost:18740/api/v1/exams/attempt/latest (empty response)

event i tried to find that 18740 port but it’s not running at all even i changed that port to 8000 still no response and same error. and i tried to find that api in whole edx-platform and venv still can’t find that api in any libraries.I googled and there is something edx_exams that has the same api and port but i can’t add that into palm because there is lots of erros and not compatible.

When i click on timed section it giving me this error
Axios Error (Response): 0 http://localhost:18740/api/v1/student/exam/attempt/course_id/course-v1:EDX+E1+0000/content_id/block-v1:EDX+E1+0000+type@sequential+block@2416800d200c44c795aa68e13c195877 (empty response)

There is no view for units or start time exam pop up nothing.
what could be the issue? Anyone can help me because i’m trying to solve this for past 1 week and i have a deadline on end of this week.

Hi @Dhruv_Brahmbhatt I think I can help you with this. That request suggests a setting that toggles some changes to exams that are still in development is enabled for you. Does your MFE environment config have a value set for EXAMS_BASE_URL?

1 Like

Hi @zhancock_edx I’m also getting this issue.Can you please guide me where can I find this EXAM_BASE_URL.

In edx-platform in both lms and cms i have this
EXAMS_SERVICE_URL = ‘http://localhost:18740/api/v1

for MFE environment i don’t know where it is( are you talking about learning?)
If learning then i have EXAMS_BASE_URL
.env: EXAMS_BASE_URL=‘’ "
.env.development: EXAMS_BASE_URL=‘http://localhost:18740
.env.test: EXAMS_BASE_URL=‘http://localhost:18740

Below is the main thing causing the issue
activeAttemptUrl = new URL(“”.concat((0, _frontendPlatform.getConfig)().EXAMS_BASE_URL, “/api/v1/exams/attempt/latest”));

Are you running tutor dev?

That value seems to have leaked into the .env.development file. It should be set to an empty string. This is fixed in master but looks like the bad state got caught up in the palm release. (fix: feat: exams svc should not be enabled by default by Zacharis278 · Pull Request #1100 · openedx/frontend-app-learning · GitHub)

1 Like

Yes i’m running dev

Thank you so much, i set that filed to empty string now it’s working as intended.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.