This is a follow-up to this thread (fortunately, the changes from the current thread are not breaking anything). As mentioned there:
Currently, various terms refer to XBlocks: “xblocks” (or “blocks”), “descriptors”, “modules”, or “items”. This makes the code a lot less approachable and understandable. Since we are getting rid of a lot of tech debt, we are doing a small refactor of this terminology in the edx-platform to make it consistent.
We have just merged the second PR from this effort. This one converts references using
item to refer to XBlocks to use
The most significant change affecting you while writing tests is that we renamed the
There are also the following changes in methods that are not widely used (you can find the reasoning behind these changes here):
Replaced iterations over
self, as this method was returning
get_children, as the result is identical.
Removed these two (already deprecated) methods, as they were not used outside of the
We have two remaining refactor tickets we’re planning to merge soon:
block(needs the final review).
block(needs some changes, as we are close to removing the ModuleSystem).
I will update this thread once we merge them to keep the context in one place.