Stuck on "make requirements" when trying install devstack

Hi there. I’m newbie. I have followed the instruction on GitHub - edx/devstack: Get up and running quickly to develop or extend Open edX services and found difficulties when execute “make requirements” on Ubuntu 20.04. All prequisites have been installed (e.g. make, python3, docker). When executed the command, it said “make: *** No rule to make target ‘requirements’. Stop.”
Any help is appreciated. Thank you.

Hello @sashiomarda and welcome to the community!

I guess you have some issues with the pip on your system (Ubuntu 20.04) as it does not support pip in the light of pip3.

make requirements hits below command under the cover:

Can you check with the above command, whether it is working?

Hello @jramnai. Yeah. It worked. Thanks. However another issue came up. The error message below came up when it reached Cloning into ‘edx-platform’

The [edx-notes-api] repo is already checked out. Checking for updates.
From https://github.com/edx/edx-notes-api
 * branch            master     -> FETCH_HEAD
Already up to date.
Cloning into 'edx-platform'...
remote: Enumerating objects: 705584, done.
remote: Counting objects: 100% (1950/1950), done.
remote: Compressing objects: 100% (1180/1180), done.
error: RPC failed; curl 56 GnuTLS recv error (-54): Error in the pull function.
fatal: the remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed
make: *** [Makefile:190: dev.clone.https] Error 128
(openedx_env) root@pusdik:/home/project_virtualenv/openedx_env/devstack#

Glad that it worked.

I faced the same last night. This has nothing to do with Open edX installation but it failed to clone the edx-platform repo 'cause it is a big repo and maybe your internet connection will be slow (which does not support a long connection). You can figure out this issue by changing the ISP or by following tweaks for slow connection.

And it is better to create a new topic for new issues, so that in the future people can easily take reference.

1 Like