Trying to activate SSL, appears to be starting correctly, but not working in browser

Fully working site on HTTP, so decided to give SSL a whirl, so Y to HTTPS during quickstart.

Service started OK, with only a couple of warnings:

WARNINGS:
?: (2_0.W001) Your URL pattern ‘edx_name_affirmation/v1/verified_name/(?P<verified_name_id>\d+)$’ [name=‘verified_name_by_id’] has a route that contains ‘(?P<’, begins with a ‘^’, or ends with a ‘$’. This was likely an oversight when migrating to django.urls.path().
consent.DataSharingConsent.granted: (fields.W903) NullBooleanField is deprecated. Support for it (except in historical migrations) will be removed in Django 4.0.
HINT: Use BooleanField(null=True) instead.
consent.HistoricalDataSharingConsent.granted: (fields.W903) NullBooleanField is deprecated. Support for it (except in historical migrations) will be removed in Django 4.0.
HINT: Use BooleanField(null=True) instead.
Creating flag: course_home.course_home_mfe_progress_tab
Setting name: course_home.course_home_mfe_progress_tab
Setting everyone: True
Setting percent: None
Setting superusers: False
Setting staff: False
Setting authenticated: False
Setting group(s):
Setting user(s): set()
Setting rollout: False
All services initialised.
The Open edX platform is now running in detached mode
Your Open edX platform is ready and can be accessed at the following urls:

https://smallscreenschool.com
https://studio.smallscreenschool.com

Have added the standard A records in the DNS, as per usual.

Is that ALL I have to do? Not getting any hits on https://smallscreenschool.com, but I AM getting returns on http://smallscreenschool.com

browser return is ERR_CONNECTION_RESET

where did I go wrong?

Matthew P

Could someone please direct me to which logs to check, in the hope of understanding where my HTTPS is going wrong? Happy to contribute to documentation if I can troubleshoot and getting it working.

Would I be better off seeking help in a Caddy forum? Is the SSL certificate generation etc handled wholly by caddy?

Matthew

Yup!

Otherwise, just a shot in the dark: can you confirm that your firewall or security group, if any, is allowing requests to port 443?

Oh, and if you look at tutor local logs caddy, that might give a hint to what’s going wrong.

Thanks for your help Adolfo! I checked the logs and saw that Caddy was only listening on Port 80. At this point I remembered that I had initially tried to install a purchased certificate (before I realised Caddy could handle all this) and as part of that process, had set the "ENABLE_WEB_PROXY flag to FALSE.

I undid this change by setting it back to it’s default of TRUE, and everything worked just fine!

Matthew P