Tutor: Error during Upgrading from Nutmeg to Olive

Hello everyone,

I am working with the openedx release nutmeg in the tutor.

I just want to upgrade tutor nutmeg to tutor olive so i followed the below steps , facing below errors when ran the tutor specific commands.

The steps which i followed:-

1) take a backup mysql and mongoDB
2) Upgrade tutor version using pip (pip install "tutor[full]==v15.3.9")
3) Do the tutor launch it gives the error
4) tutor images pull all (in dev environment)
5) tried  tutor dev upgrade --from=nutmeg gives the error

i got an below error when ran the tutor dev launch -I command

[+] Running 3/3
 ✘ discussions Error                                                                                                                                                                                   3.3s 
 ✘ course-authoring Error                                                                                                                                                                              3.3s 
 ✘ authn Error                                                                                                                                                                                         3.3s 
Error response from daemon: pull access denied for course-authoring, repository does not exist or may require 'docker login': denied: requested access to the resource is denied

and when I ran tutor dev upgrade --from=nutmeg this command then got an below error

Usage: tutor dev [OPTIONS] COMMAND [ARGS]...
Try 'tutor dev -h' for help.

Error: No such command 'upgrade'.

Please suggest some solutions or steps as i want to upgrade from nutmeg to olive on Dev and production (k8s) environment.

Thanks in Advance :slightly_smiling_face:

Try to check it with tutor local as well, if that does not help try to run it directly after building the images.
Sometimes it’ll take the old images that are in machine

okay sure.

Thanks @chintan