Video not playing. when click link(view live version) from studio page

‘Error’
Mixed Content: The page at ‘https://apps.abc.abc.tech/learning/course/course-v1:abc+ACL2020+2020_ACL/home’ was loaded over HTTPS, but requested an insecure favicon ‘http://abc.abc.tech/favicon.ico’. This request has been blocked; the content must be served over HTTPS.

Network request: http://abc.abc.tech/login_refresh
status: blocked:mixed-content)

Config
ENABLE_HTTPS: false
ENABLE_WEB_PROXY: false
PLUGINS:

  • mfe
    tutor, version 14.0.5

Note:have configuration to forward http request to https internally

This issue is pretty straight forward, in terms of what is going on fundamentally. You are mixing secure and insecure requests, http and https. I assume that https is working for you as the first URL in the error is using it. Can you changed any other config to use http?

Hi,

I still had the same problem when I used a proxy other than caddy, to solve the problems of mixed http and https content, what I did was:

  1. Change port 80 to 81
  2. ENABLE_HTTPS: true
    ENABLE_WEB_PROXY: false
  3. In my case use nginx as a reverse proxy with the following configuration.
server {
        server_name xxxx.xxxxx.com;

        location / {
                proxy_pass http://192.168.XXX.XXX:81;
                proxy_set_header Host $host;
                proxy_set_header X-Real-IP $remote_addr;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                proxy_set_header X-Forwarded-Proto $scheme;
                proxy_set_header X-Forwarded-Host $host;

                proxy_pass_request_headers on;
                                proxy_no_cache $cookie_nocache  $arg_nocache$arg_comment;
                                proxy_no_cache $http_pragma     $http_authorization;
                                proxy_cache_bypass $cookie_nocache $arg_nocache $arg_comment;
                                proxy_cache_bypass $http_pragma $http_authorization;
                proxy_set_header HTTP_AUTHORIZATION $http_authorization;
     }
}

HI, Thank you for response
Basically i am disabling. https (ENABLE_HTTPS: false) while running tutor
I ment to say i am selecting N option for last question. "Do you need to run tutor https ?.
when run tutor local quickstart.

And i am handling http to https redirection internally.

This is not the right way to proceed. See the docs: Configuration and customisation — Tutor documentation

If you would like to perform SSL/TLS termination with your own custom certificates, you will have to keep ENABLE_HTTPS=true and turn off the Caddy load balancing with ENABLE_WEB_PROXY=false. See the corresponding tutorial for more information.

Thanks @regis it helped me to fix issue.