Xblock django installation failure

Hi, so i cannot build or start making my xblock project because everytime I run
pip install -r requirements/base.txt
i run into the same ERROR: Could not find a version that satisfies the requirement django==2.2.10
after trying to install django 2.2.1 though pip it simply will not install this version until I run pip3, of course by doing this some other requirements arent fulfilled, im just not sure how to run pip install -r requirements/base.txt when pip isnt compatible with django 2.2.1? Any ideas?

Hi @shire,

Is this the xblock-sdk repository you are running this command in? It appears there were some recent requirements updates that were merged in #169 that may be causing the issues for you. If you roll back to the previous commit on master, does it work?

Curious - what requirements fail with pip3? And what is the output of pip3 --version?

when i use pip3 its wheel does not build for lxml, it just crashes over and over , as for when i try to use pip im constantly blocked by Could not find a version that satisfies the requirement django==2.2.10 im currently using pip3 19.0 ive upgrading and even this hasnt helped. When i downgrade django from 2.2.1 to 1.11.0 this successfully installs the pakages but when i run python xblock-sdk/manage.py migrate i am not prompted with You just installed Django's auth system, which means you don't have any superusers defined. Would you like to create one now? (yes/no): when i run server i am met a the deault xblock page here https://edx.readthedocs.io/projects/xblock-tutorial/en/latest/getting_started/create_first_xblock.html#run-the-xblock-sdk-server, yet the links are all missing simply the header and button are there

@shire What version of python are you using? I also had issues building lxml on python 3.8. Downgrading to python 3.5 solved it for me, because it was able to install the binary wheel, instead of trying to build from the source tarball.

I would recommend trying to get it working on python3/pip3, because python2 support is being phased out.

any update how to run xblock-sdk. Documentation is outdated I guess.