Can't display Scorm on dev: Refused to display in a frame because it set 'X-Frame-Options' to 'sameorigin'

Hi everyone,
I’m working on a development instance of Quince.1, running on a server and accesible through a custom domain name.

Everything seems to work fine, but when I add a Scorm to a unit, it show as an empty block and the browser console shows the following error: Refused to display ‘’ in a frame because it set ‘X-Frame-Options’ to ‘sameorigin’.

In previous versions it was possible to modify this in the Nginx configuration (as discussed here:, but since Tutor does not include Nginx anymore, how can I modify it?

Since I’m serving the development instance through Nginx with a proxy pass anyway, I tried to modify this setting (using proxy_set_header) but it was unsuccessful.

Thanks in advance.

Hi. Are you not using Caddy in any capacity? As per changelogs, the nginx patches are replaced with caddy patches (tutor/ at master · overhangio/tutor · GitHub). Or is Nginx only used for proxy purposes, with Caddy still running behind it?

Hi @Syed_Muhammad_Dawoud
Nginx is there only for proxy purposes, with Caddy running behind it, but this happens only in “Production mode”, if i’m not wrong (Using the command “tutor local…”)

But i’m having this problem on “Development mode”. I think that there isn’t a Caddy container in this instance.