Need help installing / enabling scorm xblock

We have installed the latest version Ironwood, but we are struggling to enable the xblock plugin. We have installed the raccoongang xblock from https://github.com/raccoongang/edx_xblock_scorm, but the xblock option doesn’t show up for our courses. We have followed the instructions about adding scormxblock to the advanced module list, and making sure we are accessing only through https. There were no errors during install. Any help is appreciated.

thanks

It’s works with https.

ok, it doesn’t work for us. we have followed the instructions on the above github xblock page. we are running Ironwood on the Ubuntu LTS 16. anything we might have missed? thanks.

can you share your log error?

we are new to this. where should we look for the logs? the install didn’t throw any error.

You can share the errors generated by either the lms or studio

/edx/var/log/{lms/cms}/edx.log

if you already added it to advanced modules, errors should be seen?

is there a way to attach the file to this conversation? I dont see any errors related to xblock.

you can share with https://pastebin.com/

we are trying to get clean logs to you. also, do we need to install devstack to get the scormxblock working?

I installed ironwood.master, enabled SSL on both lms and cms. then created a course called Shankars Test Course. then installed raccoongang xblock, but it failed with permission denied error. then ran the pip install cmd with “sudo”, this time it succeeeded.

went back to ShankarsTestCourse and enabled “scormxblock” on the advanced modules list. restarted lms, cms, workers. went back to the course and added a unit, scorm component is not showing up.

cms.log is here: https://pastebin.com/Epifn3Lf

Apr 27 05:04:34 is the entry where I’m creating the Shankars Test Course. xblock was added after that. Though there are some xblock errors before that, which I can only guess happened either during edx install or during the creation of the edx demo course. I dont know.

If you want the lms edx log, let me know.

Hi we’ve used raccoongang’s scorm xblock with the ironwood installations everything works without issues.

Please check:

  • edxapp_env contains required xblock;
  • “scormxblock” is added to the list of Advanced Module List;
  • find scorm unit among advanced units in studio.

Thank you. // edxapp_env contains required xblock; // this crucial part of the instruction was missing in the raccoongang github page. The file in my install doesn’t contain any reference to xblock. Can you tell me what exactly should I add in this file. Also, this blog post: https://blog.lawrencemcdaniel.com/how-to-install-an-xblock/ talks about compiling the assets and restart. Do I have to do that as well? Thanks a lot for your help.

thank you @idegtiarov. // edxapp_env contains required xblock // is a crucial piece of information missing from the xblock readme.md. After adding the xblock folder to the PATH in edxapp_env, it started working. The only issue we are facing right now is that the scorm xblock is always expecting index.html to be found in the root dir. It is not parsing the manifest file to find out which is the starting file. Thanks!