Configure Open edX as a SAML Service Provider

I´m following the instructions on configuring Open EdX as an SP here Configuring your Open edX Site as a SAML Service Provider

But in the steps under 4.23.4.2. Add Keys to the LMS Configuration File

It says to include the comment #SAML KEYS in lms.auth.json
It also says to add the YAML literal style indicator (|) to the paramater SOCIAL_AUTH_SAML_SP_PUBLIC_CERT
And it says to copy the content of saml.cert to the jason file after the YAML literal style indicator.

Non of these instructions are valid JSON so what gives?

This is what I get in my lms.auth.json when I follow these instructions

“SOCIAL_AUTH_SAML_SP_PUBLIC_CERT”: | -----BEGIN CERTIFICATE-----
MIIEFzCCAv+gAwIBAgIJAOPU706bZ2fvMA0GCSqGSIb3DQEBCwUAMIGhMQswCQYD
|
|
|
Ut4pEni+lqAjvp6DfyRGyeYHIBCEPjzdErN7FVIJjX3TULMGskgVAyZ+/g==
-----END CERTIFICATE-----

Can some help me understand this please? :slight_smile:
I’ve followed the docs for SSO integration including Integrating with a SAML Identity Provider but I’m not seing the SSO login button on the sign in page.

I don’t know about the YAML literal style indicator but adding it as a json value also works i.e.
"SOCIAL_AUTH_SAML_SP_PUBLIC_CERT”: “-----BEGIN CERTIFICATE-----
|
|
–END CERTIFICATE-----\n”

Once all the required fields mentioned in the doc are filled, make sure you have selected the “Enabled” flag before saving the provider configuration. The button will only be seen if it is enabled.

Thanks, I´ll try that.

Also noted that there´s an option in the Provider Configuration (SAML IdPs) called Visible and that also needs to be ticked