Devstack installation make dev.provision throwing error

received below error when I run make dev.provision on Ubuntu 22.04 system.

Run npm audit for details.
Successfully clean-installed NPM packages. Log found at /edx/app/edxapp/edx-platform/test_root/log/npm-install.log
—> pavelib.prereqs.install_python_prereqs
—> pavelib.prereqs.uninstall_python_packages
NO_PYTHON_UNINSTALL is set. No attempts will be made to uninstall old Python libs.
pip install -e .
Looking in indexes: http://edx.devstack.devpi:3141/root/pypi/+simple/, Simple index
Obtaining file:///edx/app/edxapp/edx-platform
Preparing metadata ( … done
Requirement already satisfied: setuptools in /edx/app/edxapp/venvs/edxapp/lib/python3.8/site-packages (from Open-edX==0.13) (68.0.0)
Installing collected packages: Open-edX
Running develop for Open-edX
Successfully installed Open-edX-0.13
pip install -q --disable-pip-version-check --exists-action w -r requirements/edx/development.txt
WARNING: sphinxcontrib-openapi 0.8.1 does not provide the extra ‘markdown’
pip freeze > /edx/app/edxapp/edx-platform/test_root/log/pip_freeze.log

++ docker-compose restart lms
Restarting edx.devstack.lms … done
++ docker-compose exec lms bash -c ‘source /edx/app/edxapp/edxapp_env && cd /edx/app/edxapp/edx-platform && paver update_db --settings devstack_docker’
Build failed: Unknown task: update_db
make: *** [Makefile:44:] Error 1

Any help on the above error much appreciated.

@saching5990: Your devstack code is out of sync with your edx-platform code. If you are working off master, you’ll need to do a git pull to get the latest devstack code. This is due to removal from this update_db DEPR.

@Diana_Huang: Multiple people have run into this. It might be useful to have a doc around this. If we had [idea] Create document of devstack upgrade instructions · Issue #1144 · openedx/devstack · GitHub, it might be a good place to capture this. The troubleshooting doc could mention that this other doc should also be reviewed for temporary issues from not having an up-to-date devstack.

Thank you Robert Raposa