Erorr issue install lilac.master

TASK [git_clone : Require a clean working tree] ********************************
skipping: [localhost] => (item={‘cmd’: ‘test ! -e “/edx/app/ecommerce/ecommerce” || git -C “/edx/app/ecommerce/ecommerce” status --porcelain --untracked-files=no’, ‘stdout’: ‘’, ‘stderr’: ‘’, ‘rc’: 0, ‘start’: ‘2022-07-17 03:45:48.972973’, ‘end’: ‘2022-07-17 03:45:48.974688’, ‘delta’: ‘0:00:00.001715’, ‘changed’: True, ‘invocation’: {‘module_args’: {‘_raw_params’: ‘test ! -e “/edx/app/ecommerce/ecommerce” || git -C “/edx/app/ecommerce/ecommerce” status --porcelain --untracked-files=no’, ‘_uses_shell’: True, ‘warn’: True, ‘stdin_add_newline’: True, ‘strip_empty_ends’: True, ‘argv’: None, ‘chdir’: None, ‘executable’: None, ‘creates’: None, ‘removes’: None, ‘stdin’: None}}, ‘stdout_lines’: , ‘stderr_lines’: , ‘failed’: False, ‘item’: ‘/edx/app/ecommerce/ecommerce’, ‘ansible_loop_var’: ‘item’})

TASK [git_clone : Checkout code over ssh] **************************************
skipping: [localhost] => (item=None)

TASK [git_clone : Checkout code over https] ************************************
changed: [localhost] => (item=None)
changed: [localhost]

TASK [git_clone : Remove read-only ssh key] ************************************
skipping: [localhost] => (item=None)

TASK [git_clone : Run git clean after checking out code] ***********************
failed: [localhost] (item=None) => {“censored”: “the output has been hidden due to the fact that ‘no_log: true’ was specified for this result”, “changed”: true}
fatal: [localhost]: FAILED! => {“censored”: “the output has been hidden due to the fact that ‘no_log: true’ was specified for this result”, “changed”: true}

RUNNING HANDLER [redis : reload redis] *****************************************

PLAY RECAP *********************************************************************
localhost : ok=302 changed=159 unreachable=0 failed=1 skipped=651 rescued=0 ignored=3

============================================================
Ansible failed!

Decoded error:
== censored ===========================
the output has been hidden due to the fact that ‘no_log: true’ was specified for this result

============================================================
Installation failed!

If you need help, see Connect – Open edX .
When asking for help, please provide as much information as you can.
These might be helpful:
Your log file is at /home/icei/logs/install-20220717-030934.log
Your environment:
OPENEDX_RELEASE=open-release/lilac.master

Installation finished at 2022-07-17 03:45:54

ihave this erorr for lilac.master install please help

Hi @Caesario_Satriatama welcome and thanks for joining the community! You’re trying to install the OpenedX platform in the Lilac version using the native method. Unfortunately, this installation method is deprecated from Lilac (see docs here).
Unless you’re restricted to maintaining a legacy OpenedX version older than Lilac, we recommend deploying the OpenedX platform (preferably on its latest supported version which is Nutmeg) using Tutor . I hope this helps.

I have read and followed all the documentation there, then I found the problem and error still same

@Caesario_Satriatama could you please specify the problem you had with Tutor? It is strange you get the same error since Ansible is not used in the Tutor OpenedX installation

this is i still use for native mr, I’ve used the specs as they are in the documentation and it always doesn’t work. is this a problem because I use azure as a server. because we want to use edx as one of our learning platforms

Hello ,
I am facing the same issue , any update regarding it ?

Hi @harout7, could you please indicate what installation method are you using and the description of the issue you’re experiencing? Remember we strongly recommend deploying the latest version of the OpenedX platform using Tutor

Hi @jhony_avella , thanks for writing back I was trying to do native installation using lilac version , it worked after spending few days trying to fix the issue.

please tell me how to install on azure VM thanks

@harout7 I’m glad you finally got it working! Could you please indicate what type of installation you performed (ansible-based with openedx/configuration or tutor-based) and describe briefly how you solved your issues?

@jhony_avella , It was ansible-based installation , I didn’t document the steps exactly but there were few edits in the ansible configuration and it worked , most probably it needs to be updated and maintained, since most people are not using this installation anymore.

yeah , i think i new for use ubuntu / linux command line, it’s very helpful if you show how to step of installation

@Caesario_Satriatama I have used the official documentation for devstack installation , however as I mentioned earlier I had to edit ansible configuration , its not an easy one as you need to have experience in working with ansible files , I suggest if you can share the error you are facing in the forum and if I have or know the solution I will reply.

hello @harout7 ,

i think my error has wrote on this discussion page , how about Authority Certificate for installing open Edx? is that my problem?