Install Xblock on EC2

Hi, noob here. I’ve got Open Edx running on an AWS EC2 instance and have succeeded in connecting via SSH. I’d now like to install an IBL Education xblock as detailed here. The instruction for installation is:

/edx/bin/pip.edxapp install git+https://github.com/ibleducation/jupyter-viewer-xblock.git

which I assume I am meant to type into Terminal, while connected via SSH, so that the code from the IBL repo will be installed in the direction /edx/bin. However, I get this error:

-bash: /edx/bin/pip.edxapp: No such file or directory

This stumps me and I’m not sure what to do next. Why does that directory not exist? How can I get this code installed?
Thanks.

sudo -H -u edxapp bash
source ~/edxapp_env
pip install git+https://github.com/ibleducation/jupyter-viewer-xblock.git

This should do the trick.

Thanks for your reply. When I do
sudo -H -u edxapp bash
I get:
sudo: unknown user: edxapp
sudo: unable to initialize policy plugin

Usually edxapp user is there by default.

Was this tutor installation ?

If yes please refer the link over here`

Yes, tutor installation, everything completely default so far.
I referred to your link, which I had seen and tried earlier. I tried the example given:
echo "git+https://github.com/open-craft/xblock-poll.git" >> "$(tutor config printroot)/env/build/openedx/requirements/private.txt"
and that goes through with no error. But when I try to rebuild the docker image with:
tutor images build openedx
I get the following lengthy error message:
Building image docker.io/overhangio/openedx:11.1.3
docker build -t docker.io/overhangio/openedx:11.1.3 /home/ubuntu/.local/share/tutor/env/build/openedx

Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.24/build?buildargs=%7B%7D&cachefrom=%5B%5D&cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=Dockerfile&labels=%7B%7D&memory=0&memswap=0&networkmode=default&rm=1&shmsize=0&t=docker.io%2Foverhangio%2Fopenedx%3A11.1.3&target=&ulimits=null&version=1: dial unix /var/run/docker.sock: connect: permission denied

Error: Command failed with status 1: docker build -t docker.io/overhangio/openedx:11.1.3 /home/ubuntu/.local/share/tutor/env/build/openedx

tutor has different user

If I am not wrong probably edx

So
su edx
or
sudo -H -u edx bash

and then your commands can help you.

If it still doesn’t @regis would be the right guy to answer your questions.

Or you can ask them at https://discuss.overhang.io/

Thanks for pinging me @chintan :slight_smile: For the record, since Tutor is now one of the officially supported installation methods for Open edX, we should actually answer Tutor-related here. I see that @William_Kowalski has already opened a new topic on the overhang.io forums so I’ll answer there: Unable to install Xblocks or rebuild docker image - Tutor - Overhang.IO

1 Like