Xblock installation tutor

Hi Everyone,
I am not able to install cutomized SGA xblock in tutor Open edX.
I have added github repo in config.yml

- "git+https://github.com/open-craft/xblock-poll.git"

like above, then i build image, and start the server.
but still not working.
in build image first installing customized SGA xblock,
but then after it attempting uninstall to customized XBLOCK,
and re-install default one.
please help if you have any soution.

I use private.txt to install xblock. Using OPENEDX_EXTRA_PIP_REQUIREMENTS didn’t work for me before.

Is this your “dev” environment or “local” environment?
or after adding in the private.txt, should I need to build an image every time?

It worked for me in all env.
As the docs mentioned you must run “tutor images build openedx”

I tried this way, but the same thing happen,
first, install, and at the end of the build, it is re-install the default version.

cd “$(tutor config printroot)/env/build/openedx/requirements”
vim private.txt
paste this to the file: git+https://github.com/open-craft/xblock-poll.git
save the file
tutor images build openedx
tutor restart -d
Add the xblock name to Advanced Module list.
If you are using k8s then you have to push the image to your registry and reference the image in your tutor settings.


xblock-poll is not SGA.
SGA is installed by default in Nutmeg, so you don’t need to add anything to pip requirements. You must add “edx_sga” to the advanced module list.