"Installing the Open edX Analytics Developer Stack" ansible broken dependency

When I do the instructions here: Installing the Open edX Analytics Developer Stack, within an Ubuntu 20.04 Linux system, first I get:

user2@user2-virtual-machine:~/Documents/edx-analytics-pipeline$ virtualenv venv
Command ‘virtualenv’ not found, but can be installed with:
sudo apt install python3-virtualenv

(I confirmed I have VirtualBox 6.1.18 from Oracle’s Linux Downloads site for Ubuntu 20.04 installed fine, but it doesn’t seem to add a “virtualenv” command to my path).

Then the “make bootstrap” command fails due to a missing prerequisite for Ansible

(venv) user2@user2-virtual-machine:~/Documents/edx-analytics-pipeline$ make bootstrap
pip install -r requirements/pip.txt
Requirement already satisfied: pip==9.0.1 in ./venv/lib/python3.8/site-packages (from -r requirements/pip.txt (line 1))
Requirement already satisfied: setuptools==36.4.0 in ./venv/lib/python3.8/site-packages (from -r requirements/pip.txt (line 2))
Requirement already satisfied: wheel==0.30.0 in ./venv/lib/python3.8/site-packages (from -r requirements/pip.txt (line 3))
You are using pip version 9.0.1, however version 21.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
pip uninstall -y edx.analytics.tasks
Cannot uninstall requirement edx.analytics.tasks, not installed
You are using pip version 9.0.1, however version 21.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
make: [Makefile:6: uninstall] Error 1 (ignored)
python setup.py clean
running clean
pip install -r requirements/base.txt --no-cache-dir
Collecting ansible==1.4.5 (from -r requirements/base.txt (line 9))
  Downloading https://files.pythonhosted.org/packages/1c/8a/46733115b6469b0ac5d557af88284904335ac3c0306e1298a877d4906151/ansible-1.4.5.tar.gz (483kB)
100% |████████████████████████████████| 491kB 49.8MB/s 
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/tmp/pip-build-l6dxcvku/ansible/setup.py", line 12, in <module>
    from ansible.constants import DEFAULT_MODULE_PATH
  File "/tmp/pip-build-l6dxcvku/ansible/lib/ansible/constants.py", line 21, in <module>
    import ConfigParser
ModuleNotFoundError: No module named 'ConfigParser'

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-l6dxcvku/ansible/
You are using pip version 9.0.1, however version 21.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
make: *** [Makefile:13: bootstrap] Error 1

FWIW I do the “pip install --upgrade pip” command and it upgrades to v 21, but then it seems like it gets downgraded again by the Ansible installer?

(venv) user2@user2-virtual-machine:~/Documents/edx-analytics-pipeline$ make bootstrap
pip install -r requirements/pip.txt
Collecting pip==9.0.1
  Using cached pip-9.0.1-py2.py3-none-any.whl (1.3 MB)
Requirement already satisfied: setuptools==36.4.0 in ./venv/lib/python3.8/site-packages (from -r requirements/pip.txt (line 2)) (36.4.0)
Requirement already satisfied: wheel==0.30.0 in ./venv/lib/python3.8/site-packages (from -r requirements/pip.txt (line 3)) (0.30.0)
Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 21.0
    Uninstalling pip-21.0:
      Successfully uninstalled pip-21.0
Successfully installed pip-9.0.1

Also I do “pip install ConfigParser” but it says it’s already installed:

(venv) user2@user2-virtual-machine:~/Documents/edx-analytics-pipeline$ pip install ConfigParser
Requirement already satisfied: ConfigParser in ./venv/lib/python3.8/site-packages

But the make bootstrap command continues to fail.

So at this point I’m out of ideas on how to proceed.

Could this be related in part because of this?
https://openedx.atlassian.net/browse/DEPR-119

I’ve also been trying to install Insights under Ubuntu 20.04 without success under a native environment.

Seems plausible. With no apparent alternative at the moment?