Open edx installation error

Hello everyone,I have installed bootstrap ansible and other things as per documentation,Now I am facing problem while installing openedx ,my error log is,

ERROR: Cannot uninstall ‘PyYAML’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.
WARNING: You are using pip version 20.0.2; however, version 21.1.3 is available.
You should consider upgrading via the ‘/usr/bin/python3 -m pip install --upgrade pip’ command.
sudo: ansible-playbook: command not found

============================================================
Ansible failed!

Decoded error:
Traceback (most recent call last):
File “/var/tmp/configuration/util/ansible_msg.py”, line 26, in
junk = junk[junk.index(’=> {’)+3:]
ValueError: substring not found

============================================================
Installation failed!

If you need help, see Connect – Open edX .
When asking for help, please provide as much information as you can.
These might be helpful:
Your log file is at /media/muntasir/Workstation/openedx_native/logs/install-20210703-230018.log
Your environment:
OPENEDX_RELEASE=open-release/lilac.1
VTE_VERSION=6003

Installation finished at 2021-07-03 23:00:51

I am very much stuck with this,please someone help me.I have updated pyYAML also,but still getting this error

Can you post the full error log? It’s hard to tell what the problem is without more context.

Hello erveryone ,I am very stuck at installing openedx,mI have 8 gb of Ram,ubuntu 20.04,core-if configuration,I have tried almost 1 week,recently I have reinstall ubuntu 20.04 to install it,But still I am facing this error,
Link for log file is attached ,please use this link,
link:log file

please help me,I need to solve this.

thank you sir,I have solved above error,but now the error is Full log file Please sir help me to solve this

Anyone please help me to solve this problem

@Md.Muntasir_Mamun, hi! The error you’re hitting is a known one:

In short, what happens is that when you run the playbooks a second time, the Mongo 4.0 ones will fail when setting up the replica set. A fix is being worked on, but in the meantime, would it be possible for you to try installing from scratch?