Mongod Default-Start contains no runlevels - Ginkgo.1 installation

Dear all,

when I try to install ginkgo.1, I get the following error:

link to logfile

My system: Ubuntu 16.04 LTS, 8 Gb Ram

TASK [mongo : Add mongod systemd configuration on 16.04] ***********************
changed: [localhost]

TASK [mongo : enable mongod systemd unit on 16.04] *****************************
**fatal: [localhost]: FAILED! => {"changed": false, "failed": true, "msg": "Unable to enable service mongod: Synchronizing state of mongod.service with SysV init with /lib/systemd/systemd-sysv-install...\nExecuting /lib/systemd/systemd-sysv-install enable mongod\nThe script you are attempting to invoke has been converted to an Upstart\njob, but lsb-header is not supported for Upstart jobs.\ninsserv: warning: script 'mongod' missing LSB tags and overrides\ninsserv: Default-Start undefined, assuming empty start runlevel(s) for script `mongod'\ninsserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `mongod'\nupdate-rc.d: error: mongod Default-Start contains no runlevels, aborting.\n"}**

RUNNING HANDLER [mongo : restart mongo] ****************************************
	to retry, use: --limit @/var/tmp/configuration/playbooks/edx_sandbox.retry

PLAY RECAP *********************************************************************
localhost                  : ok=76   changed=46   unreachable=0    failed=1   

I found a forum post from 2017 with a similar problem, but without a solution.

Thank you for your help.

1 Like