Problem with native installation on Ubuntu 16.04

Hello,

I tried to install openEdx on a clean Ubuntu 16.04 Cloud server hosted by Gandi.
I followed instructions at https://openedx.atlassian.net/wiki/spaces/OpenOPS/pages/146440579/Native+Open+edX+platform+Ubuntu+16.04+64+bit+Installation,
doing

export OPENEDX_RELEASE=open-release/ironwood.master
# Creating config.yml
wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/ansible-bootstrap.sh -O - | sudo bash
. /edx/app/edx_ansible/venvs/edx_ansible/bin/activate
wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/native.sh -O - | bash

But I get errors with mongod. I installed mongodb-3.2 following https://docs.mongodb.com/v3.2/tutorial/install-mongodb-on-ubuntu/ , but still the same.

I think maybe it’s a problem with disable-transparent-hugepages unit. because of following error in the log:

fatal: [localhost]: FAILED! => {“changed”: false, “failed”: true, “msg”: “Unable to start service disable-transparent-hugepages: Job for disable-transparent-hugepages.service failed because the control process exited with error code. See “systemctl status disable-transparent-hugepages.service” and “journalctl -xe” for details.\n”}

When I try to connect to the server , I’m redirected to server-error.html
Thanks for your help

Same error doing it again from scratch.

TASK [mongo_3_2 : Enable/start disable transparent huge pages service (http://docs.mongodb.org/manual/tutorial/transparent-huge-pages/)] ***
fatal: [localhost]: FAILED! => {"changed": false, "failed": true, "msg": "Unable to start service disable-transparent-hugepages: Job for disable-transparent-hugepages.service failed because the control process exited with error code. See \"systemctl status disable-transparent-hugepages.service\" and \"journalctl -xe\" for details.\n"}
	to retry, use: --limit @/var/tmp/configuration/playbooks/openedx_native.retry

Full clean log at gist.github

@garage_num, What does systemctl status disable-transparent-hugepages.service show?

Since transparent hugepages is a kernel level option, certain virtualization technologies won’t allow it to be modified from within a container. I think Gandi Cloud Server uses Xen virtualization, which may not allow transparent hugepages to be disable for your server.

Mongo will still function with them enabled, though it may affect performance.

To skip installing the service which disables transparent hugepages, you can download the native.sh script, and add an option when running.

Instead of the last step where you download native.sh and pipe it directly to bash, try running the following:

wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/native.sh
bash ./native.sh --skip-tags hugepages
1 Like

Yes it works, thank you very much!
I sent an email to Gandi support to see if there’s a way not to skip this setting.