New Tutor Open edX Site - Initial Setup About {terms_link}


On, below is the code to define “I agree to the Terms of Service”

label = Text(_(
“I agree to the {platform_name} {terms_of_service_link_start}{terms_of_service}{terms_of_service_link_end}”
platform_name=configuration_helpers.get_value(“PLATFORM_NAME”, settings.PLATFORM_NAME),

How to reduce:
Tutor: 15.3.6

I would like to know where to define the variable {terms_link}.

Please advise, many thanks!

Is {terms_link} defined from django admin panel?

or via yml file?

{terms_link} is a variable that is used locally in the code.

Can you check if ENABLE_MKTG_SITE is set to true in your site configurations or settings.Features?

Where you define that value depends on this setting.

If it’s true, you can set it in site configurations in the admin panel and yml file both. If not, it’s to be done in yml file. The variable name also changes according to the ENABLE_MKTG_SITE setting

Many thanks for your reply!

May I know if `ENABLE_MKTG_SITE is defined in openedx’s ADMIN panel or or ecommerce’s ADMIN panel?


FYI. I tried the following:

tutor config printvalue ENABLE_MKTG_SITE
Error: Missing configuration value: ENABLE_MKTG_SITE

(my site uses default)

It can be found in site configurations or and you might want to check config.yml as well.

Refer to this function to see how it works:

"HONOR" is the value passed to parameter name to get the value you are looking for.

Thanks again for your reply.

May I have the sample command to set “HONOR”?

Would it be the following?

tutor config save --set HONOR=‘’

On the registration page:

By creating an account, you agree to the Terms of Service and Honor Code in a new tab and you acknowledge that MY_SITE_NAME and each Member process your personal data in accordance with the Privacy Policy in a new tab.

Where [Terms of Service and Honor Code in a new tab]
points to incorrect page which does not exist on my site:
(the correct URL should be: https://MY_SITE_NAME/tos)

Same, [Privacy Policy in a new tab]
points to incorrect page which also does not exist on my site:
(the correct URL should be: https://MY_SITE_NAME/privacy)

Please help!

I don’t think this command will work. It needs to be in settings.MKTG_URL_LINK_MAP like this:

I haven’t tried changing this myself yet but here’s a post I found that may be relevant: