Open edX devstack installation error on Ubuntu 16.04

I am installing open edx on ubuntu 16.4 using below link tutorial https://edx.readthedocs.io/projects/edx-installing-configuring-and-running/en/latest/installation/index.html.

While hitting below command i am facing issues

make dev.provision

    ++ docker-compose exec -T lms bash -c 'source /edx/app/edxapp/edxapp_env && cd /edx/app/edxapp/edx-platform && NO_PYTHON_UNINSTALL=1 paver install_prereqs'
Traceback (most recent call last):
  File "/edx/app/edxapp/venvs/edxapp/bin/paver", line 11, in <module>
    sys.exit(main())
  File "/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/paver/tasks.py", line 890, in main
    _launch_pavement(args)
  File "/edx/app/edxapp/venvs/edxapp/local/lib/python2.7/site-packages/paver/tasks.py", line 858, in _launch_pavement
    exec(compile(source, environment.pavement_file, 'exec'), mod.__dict__)
  File "pavement.py", line 14, in <module>
    from pavelib import *
  File "pavelib/__init__.py", line 6, in <module>
    from . import assets, bok_choy, database, docs, i18n, js_test, prereqs, quality, servers, tests
  File "pavelib/assets.py", line 24, in <module>
    from .utils.envs import Env
  File "pavelib/utils/envs.py", line 331
    file=sys.stderr,
        ^
SyntaxError: invalid syntax
Makefile:57: recipe for target 'dev.provision.run' failed
make: *** [dev.provision.run] Error 1

Somehow you are running Python 2. How did you set up your Python environment?

1 Like

@rmtest did you resolve this @nedbat any help will be much appreciated thank you.

@oma0256 There’s not enough information here to figure out why this failure is happening. If it is happening to you, give us specifics about what you did, and what happened.

I have been following this article to install open-edx devstack version on my laptop, however when ever I run make dev.provision, I get the same error as above.

Those instructions mention Hawthorn, as in open-release/hawthorn.master. Are you trying to install Hawthorn?

I’m not really familiar with the versions trying to get open edx up and running on my machine as fast as possible.

@oma0256, for exploring the platform or to know about features and it’s working, try using bitnami openedx virtual machine.

@chinmaybhatk thank you I have that setup though I really preferred the devstack version for development. I had it on my machine somehow deleted it but now having trouble putting it back, guess I will settle for bitnami for now. Thank you.

1 Like