Error installing Open edX on Ubuntu 20.04

I run the following command “make dev.provision” and get the following error

File “/edx/app/edxapp/venvs/edxapp/lib/python3.5/site-packages/django/core/man agement/commands/migrate.py”, line 90, in handle
executor.loader.check_consistent_history(connection)
File “/edx/app/edxapp/venvs/edxapp/lib/python3.5/site-packages/django/db/migra tions/loader.py”, line 299, in check_consistent_history
connection.alias,
django.db.migrations.exceptions.InconsistentMigrationHistory: Migration commerce .0001_data__add_ecommerce_service_user is applied before its dependency user_api .0002_retirementstate_userretirementstatus on database ‘default’.

Captured Task Output:

—> pavelib.servers.update_db
—> pavelib.prereqs.install_prereqs
—> pavelib.prereqs.install_node_prereqs
—> pavelib.prereqs.install_python_prereqs
—> pavelib.prereqs.uninstall_python_packages
pip freeze > /edx/app/edxapp/edx-platform/test_root/log/pip_freeze.log
NO_EDXAPP_SUDO=1 EDX_PLATFORM_SETTINGS_OVERRIDE=devstack_docker /edx/bin/edxapp- migrate-lms --traceback --pythonpath=.

Build failed running pavelib.servers.update_db: Subprocess return code: 1
make: *** [Makefile:44: dev.provision.run] Error 1

Also tried installing on ubuntu 16.04 as per the instructions

https://openedx.atlassian.net/wiki/spaces/OpenOPS/pages/146440579/Native+Open+edX+platform+Ubuntu+16.04+64+bit+Installation

Step 4 - Doesn’t work!!! Gives a 404 error

wget https: // raw.githubusercontent.com / edx / configuration / $OPENEDX_RELEASE / util / install / ansible - bootstrap.sh - O - | sudo - E bash

Did you define OPENEDX_RELEASE as instructed? Your line has some extra spaces in it, I’m not sure if you had them when you ran it. It should be “ansible-bootstrap.sh”, not “ansible - bootstrap.sh”

1 Like

open-release/ficus.4 was defined in step 1 meaning

export OPENEDX_RELEASE=open-release/ficus.4

In step 3 This exact command was entered
wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/ansible-bootstrap.sh -O - | sudo -E bash

Are you saying I should substitute ‘open-release/ficus.4’ for ‘$OPENEDX_RELEASE’ in step 3

No, you don’t have to edit the line, the environment variable you exported should be used automatically.

But Ficus is three years old. The installation instructions have changed since then, though I’m not sure that’s the source of the problem. This is the page as it looked when Ficus was released: https://openedx.atlassian.net/wiki/pages/viewpage.action?pageId=146440579&pageVersion=10

Is it ok to install juniper.2 on ubuntu 16.04?

I went ahead through the steps to install Juniper.2 on clean install of ubuntu 16.04 following

https://openedx.atlassian.net/wiki/spaces/OpenOPS/pages/146440579/Native+Open+edX+platform+Ubuntu+16.04+64+bit+Installation

I was able to complete steps 1 - 4 successfully with no errors.

Step 5 I get the following 404 error
wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/native.sh -O - | bash
–2020-08-21 20:55:21-- https://raw.githubusercontent.com/edx/configuration//util/install/native.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 151.101.204.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.204.133|:443… connected.
HTTP request sent, awaiting response… 404 Not Found
2020-08-21 20:55:22 ERROR 404: Not Found.

If you look at the URL in the wget output, you can see that it is missing the $OPENEDX_RELEASE value:

https://raw.githubusercontent.com/edx/configuration//util/install/native.sh

I don’t know how you defined it, but it’s not being found in this step.

Re ran it again same error.

wget https://raw.githubusercontent.com/edx/configuration/$OPENEDX_RELEASE/util/install/native.sh -O - | bash

–2020-08-21 22:59:03-- https://raw.githubusercontent.com/edx/configuration/the-tag/open-release/juniper.2/util/install/native.sh

Resolving raw.githubusercontent.com (raw.githubusercontent.com)… 151.101.204.133

Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.204.133|:443… connected.

HTTP request sent, awaiting response… 404 Not Found

2020-08-21 22:59:03 ERROR 404: Not Found.

Rebooted the server and re-ran step 1 then step 5 and it worked

A post was split to a new topic: Install failure during “edxlocal: create databases”