ORA file upload failed showing 413 error on console (No error in the logs)

Hello guys I am facing this issue when uploading any file of more than 30 MB on my edx-development (production settings) but this error does not reproduce on the local environment. I have ORA configured to my local settings.
Any leads would be appreciated in this regard

413 error looks like an error that would be raised by the web proxy, which would explain why it is not triggered in the devstack: 413 Payload Too Large - HTTP | MDN
How did you deploy Open edX? With Tutor or the native installation? What version are you running?

With native installation. edx-version koa.2a

This issue has been resolved as it was an nginx settings that needed to be updated. I was facing error while uploading files more than 20MB in ORA. Earlier when we were using cloud (AWS) storage no issues occurred but when tried to upload files on filesystem we also needed to update settings in /etc/nginx/sites-enabled/lms for the key client_max_body_size. You can set the maximum upload size to as much as you want. In my case this worked.