Skip some registration steps

请问大家怎样才能跳过注册的一些注册步骤,初始的步骤太多了,譬如我想只设置一个名字,并且我想删除这个support框,请问我应该怎么做。
image

1 Like

You can take a look at these settings for a start.

2 Likes

I have read similar posts and configurations, but I use openedx installed by tutor. Sorry, I should make it clear in advance. It seems that tutor does not have this configuration item

Oh, the tutor has a similar configuration. I’ll try it now

This is the lms.env.json of others in the Forum,
image
This is mine. There is no such configuration item in it。
{
“SITE_NAME”: “local.overhang.io”,
“BOOK_URL”: “”,
“LOG_DIR”: “/openedx/data/logs”,
“LOGGING_ENV”: “sandbox”,
“OAUTH_OIDC_ISSUER”: “http://local.overhang.io/oauth2”,
“PLATFORM_NAME”: “My Open edX”,
“FEATURES”: {

"CERTIFICATES_HTML_VIEW": true,
"PREVIEW_LMS_BASE": "preview.local.overhang.io",
"ENABLE_CORS_HEADERS": true,
"ENABLE_COURSE_DISCOVERY": true,
"ENABLE_COURSEWARE_SEARCH": true,
"ENABLE_CSMH_EXTENDED": false,
"ENABLE_DASHBOARD_SEARCH":  true,
"ENABLE_COMBINED_LOGIN_REGISTRATION": true,
"ENABLE_GRADE_DOWNLOADS": true,
"ENABLE_LEARNER_RECORDS": false,
"ENABLE_MOBILE_REST_API": true,
"ENABLE_OAUTH2_PROVIDER": true,
"ENABLE_THIRD_PARTY_AUTH": true,
"MILESTONES_APP": true,
"ENABLE_PREREQUISITE_COURSES": true

},
“LMS_ROOT_URL”: “http://local.overhang.io”,
“CMS_ROOT_URL”: “http://studio.local.overhang.io”,
“CMS_BASE”: “studio.local.overhang.io”,
“LMS_BASE”: “local.overhang.io”,
“CONTACT_EMAIL”: “contact@local.overhang.io”,
“CELERY_BROKER_TRANSPORT”: “redis”,
“CELERY_BROKER_HOSTNAME”: “redis:6379”,
“CELERY_BROKER_VHOST”: “0”,
“CELERY_BROKER_USER”: “”,
“CELERY_BROKER_PASSWORD”: “”,
“ALTERNATE_WORKER_QUEUES”: “cms”,
“ENABLE_COMPREHENSIVE_THEMING”: true,
“COMPREHENSIVE_THEME_DIRS”: ["/openedx/themes"],
“STATIC_ROOT_BASE”: “/openedx/staticfiles”,
“EMAIL_BACKEND”: “django.core.mail.backends.smtp.EmailBackend”,
“EMAIL_HOST”: “smtp”,
“EMAIL_PORT”: 8025,
“EMAIL_USE_TLS”: false,
“ACE_ROUTING_KEY”: “edx.lms.core.default”,
“HTTPS”: “off”,
“LANGUAGE_CODE”: “en”,
“SESSION_COOKIE_DOMAIN”: “local.overhang.io”,

“CACHES”: {
“default”: {
“KEY_PREFIX”: “default”,
“VERSION”: “1”,
“BACKEND”: “django_redis.cache.RedisCache”,
“LOCATION”: “redis://@redis:6379/1”
},
“general”: {
“KEY_PREFIX”: “general”,
“BACKEND”: “django_redis.cache.RedisCache”,
“LOCATION”: “redis://@redis:6379/1”
},
“mongo_metadata_inheritance”: {
“KEY_PREFIX”: “mongo_metadata_inheritance”,
“TIMEOUT”: 300,
“BACKEND”: “django_redis.cache.RedisCache”,
“LOCATION”: “redis://@redis:6379/1”
},
“staticfiles”: {
“KEY_PREFIX”: “staticfiles_lms”,
“BACKEND”: “django.core.cache.backends.locmem.LocMemCache”,
“LOCATION”: “staticfiles_lms”
},
“configuration”: {
“KEY_PREFIX”: “configuration”,
“BACKEND”: “django_redis.cache.RedisCache”,
“LOCATION”: “redis://@redis:6379/1”
},
“celery”: {
“KEY_PREFIX”: “celery”,
“TIMEOUT”: “7200”,
“BACKEND”: “django_redis.cache.RedisCache”,
“LOCATION”: “redis://@redis:6379/1”
},
“course_structure_cache”: {
“KEY_PREFIX”: “course_structure”,
“TIMEOUT”: “7200”,
“BACKEND”: “django_redis.cache.RedisCache”,
“LOCATION”: “redis://@redis:6379/1”
},
“ora2-storage”: {
“KEY_PREFIX”: “ora2-storage”,
“BACKEND”: “django_redis.cache.RedisCache”,
“LOCATION”: “redis://@redis:6379/1”
}
},
“SECRET_KEY”: “L6CSVV4XeCXaVXmuRM4El3L4”,
“AWS_ACCESS_KEY_ID”: “”,
“AWS_SECRET_ACCESS_KEY”: “”,
“CONTENTSTORE”: null,
“DOC_STORE_CONFIG”: null,

“XQUEUE_INTERFACE”: {
“django_auth”: null,
“url”: null
},
“DATABASES”: {
“default”: {
“ENGINE”: “django.db.backends.mysql”,
“HOST”: “mysql”,
“PORT”: 3306,
“NAME”: “openedx”,
“USER”: “openedx”,
“PASSWORD”: “Ws14R6aw”,
“ATOMIC_REQUESTS”: true,
“OPTIONS”: {
“init_command”: “SET sql_mode=‘STRICT_TRANS_TABLES’”
}
}
},
“EMAIL_HOST_USER”: “”,
“EMAIL_HOST_PASSWORD”: “”
}

You should use the python file created by Tutor instead of the Yaml files.
You will need to write a plugin to change those settings.

The order is tutor common_all.py → tutor common_lms.py → tutor production.py / tutor development.py.

The last configuration files are located here: tutor/tutor/templates/apps/openedx/settings/lms at master · overhangio/tutor · GitHub for LMS and tutor/tutor/templates/apps/openedx/settings/cms at master · overhangio/tutor · GitHub for CMS.

Check these files and the files they import. Try to use the last patches {{ patch(“openedx-cms-production-settings”) }} and {{ patch(“openedx-lms-production-settings”) }} and see if that works.

1 Like

Thank you very much, I will try it now!

Thank you very much for your help. I have solved my problem