The password reset link does not work (have 'none' in place of the domain name)

Recently I installed Open edX on my own server. Next, I configured Gmail as the SMTP server. When I request a password reset link, I can receive the password resetting email properly. The problem is, The link containing the password reset link is not working properly as following image.

image

One thing I observed is that the URL has the ‘none’ keyword in place of the domain name that I have. When I replace the ‘none’ keyword with my domain name it works properly. What I want to know is, Is there any configuration I have to do to correct this? Or is this a bug?

Your help is greatly appreciated

@Achi the bug is reported here
You can set AUTHN_MICROFRONTEND_DOMAIN =“{{ MFE_HOST }}/{{ MFE_AUTHN_MFE_APP[“name”] }}”
to fix it.

Thanks but where/how to set it? Is it via “tutor config save --set” or via patch?

I use a plugin, I think the command you mentioned should work, just try it.

I am getting the same problem, since the recent update. I tried to set it in the configuration file

tutor config save --set

But MYMFE_MFE_APP does not exit.

I tried with MFE_AUTHN_MFE_APP as suggested, still getting the same none value in url.

You should set AUTHN_MICROFRONTEND_DOMAIN = the actual value of your site, something like:
AUTHN_MICROFRONTEND_DOMAIN = “apps.lms.example.com/authn
To check our MFE_HOST, use “tutor config printvalue MFE_HOST”

Thank you @Anh_Vu_Nguy_n for your response. Yes, I tested using both AUTHN_MICROFRONTEND_DOMAIN and AUTHN_MICROFRONTEND_URL. None of them worked!

I’m using a plugin like this:

from tutor import hooks

hooks.Filters.ENV_PATCHES.add_item(
    (
        "openedx-lms-production-settings",
"""
AUTHN_MICROFRONTEND_DOMAIN = "apps.lms.example.com/authn"
"""
    )
)

Where apps.lms.example.com is your MFE_HOST

3 Likes

@Anh_Vu_Nguy_n Thanks a lot. You saved my day !!. Seems working

This issue was fixed by @Anh_Vu_Nguy_n (thanks!) here. The fix will be included in tutor-mfe==15.0.5 which will be released in a few minutes.