Tutor dev quickstart initialized, but the local.overhang.io cannot be accessed

the tutor dev quickstart runs till the end (when the terminal telling us to open the local.overhang.io:8000) but when I opened it, it won’t work.

the lms and cms container is also restarting with this error logs

Traceback (most recent call last):
File “./manage.py”, line 103, in
File “/openedx/edx-platform/lms/startup.py”, line 20, in run
File “/openedx/venv/lib/python3.8/site-packages/django/init.py”, line 19, in setup
configure_logging(settings.LOGGING_CONFIG, settings.LOGGING)
File “/openedx/venv/lib/python3.8/site-packages/django/utils/log.py”, line 75, in configure_logging
File “/opt/pyenv/versions/3.8.12/lib/python3.8/logging/config.py”, line 808, in dictConfig
File “/opt/pyenv/versions/3.8.12/lib/python3.8/logging/config.py”, line 570, in configure
raise ValueError('Unable to configure handler ’
ValueError: Unable to configure handler ‘local’
Traceback (most recent call last):
File “/opt/pyenv/versions/3.8.12/lib/python3.8/logging/config.py”, line 563, in configure
handler = self.configure_handler(handlers[name])
File “/opt/pyenv/versions/3.8.12/lib/python3.8/logging/config.py”, line 744, in configure_handler
result = factory(**kwargs)
File “/opt/pyenv/versions/3.8.12/lib/python3.8/logging/handlers.py”, line 435, in init
logging.FileHandler.init(self, filename, mode, encoding, delay)
File “/opt/pyenv/versions/3.8.12/lib/python3.8/logging/init.py”, line 1147, in init
StreamHandler.init(self, self._open())
File “/opt/pyenv/versions/3.8.12/lib/python3.8/logging/init.py”, line 1176, in _open
return open(self.baseFilename, self.mode, encoding=self.encoding)
PermissionError: [Errno 13] Permission denied: ‘/openedx/data/logs/all.log’

any idea on how to solve this issue?

I found this old post and it seems the problem was about a file permission and can be resolved using sudo chown.

but I don’t know how to “sudo” it… anyone can help me?

also I may found another way which is changing the first parameter passed in the docker-compose.yml file in $(tutor config printroot)/env/dev/

command: [“0”, “/openedx/data”, “/openedx/media”]
command: [“0”, “/openedx/data”, “/openedx/media”]

but I don’t know how to apply the change? anyone can help me on this one too?