Tutor images build openedx - generate a package-lock.json file, then try again

Hi all, I’m getting an error running tutor images build openedx

any ideas? Tried searching forums but didn’t seem to find something related, sorry if repost

tutor@TutorLMS:~$ tutor --version
tutor, version 16.0.5
tutor@TutorLMS:~$ docker --version
Docker version 24.0.5, build ced0996
tutor@TutorLMS:~$ docker compose version
Docker Compose version v2.20.2

 => ERROR [nodejs-requirements 4/4] RUN npm clean-install --no-audit --registry=https://registry.npmjs.org/                                   15.6s
 > [nodejs-requirements 4/4] RUN npm clean-install --no-audit --registry=https://registry.npmjs.org/:
2.135 npm ERR! The `npm ci` command can only install with an existing package-lock.json or
2.135 npm ERR! npm-shrinkwrap.json with lockfileVersion >= 1. Run an install with npm@5 or
2.137 npm ERR! later to generate a package-lock.json file, then try again.
2.141 npm ERR! A complete log of this run can be found in:
2.141 npm ERR!     /root/.npm/_logs/2023-08-17T12_58_36_946Z-debug-0.log
 114 |     ARG NPM_REGISTRY=https://registry.npmjs.org/
 115 |     WORKDIR /openedx/edx-platform
 116 | >>> RUN npm clean-install --no-audit --registry=$NPM_REGISTRY
 117 |
 118 |     ###### Production image with system and python requirements
ERROR: failed to solve: process "/bin/sh -c npm clean-install --no-audit --registry=$NPM_REGISTRY" did not complete successfully: exit code: 1
Error: Command failed with status 1: docker buildx build --tag=docker.io/overhangio/openedx:16.0.5 --output=type=docker --cache-from=type=registry,ref=docker.io/overhangio/openedx:16.0.5-cache /home/tutor/.local/share/tutor/env/build/openedx

looking into the docker images, it appears like the lms/cms containers do have the package-lock.json file, not sure if that means anything

app@5968e5f22f8f:~/edx-platform$ ls -la | grep package-lock
-rw-r--r--    1 app app 1198795 Aug  9 20:47 package-lock.json

I have no idea what specifically fixed this but it seems to be working now. I must have missed a step trying to fix my theme.