Tutor local quickstart fails with npm timeout

Hello I’m trying to install tutor / openEdx on a fresh Fedora 36 installation.
After typing ‘tutor local quickstart’ I get a timeout error. I have the latest docker/docker-composer installed (as per the directions on the docker website…not from the local fedora repo)
Here’s the message that tutor gives me before it gives up:

> [account-dev 3/5] RUN npm clean-install --no-audit --no-fund --registry=https://registry.npmjs.org/   && rm -rf ~/.npm:
#0 29.00 npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
#0 29.57 npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See https://v8.dev/blog/math-random for details.
#0 32.33 npm WARN deprecated source-map-url@0.4.1: See https://github.com/lydell/source-map-url#deprecated
#0 32.35 npm WARN deprecated source-map-resolve@0.5.3: See https://github.com/lydell/source-map-resolve#deprecated
#0 33.62 npm WARN deprecated sane@4.1.0: some dependency vulnerabilities fixed, support for node < 10 dropped, and newer ECMAScript syntax/features added
#0 33.88 npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
#0 34.21 npm WARN deprecated superagent@3.8.3: Please upgrade to v7.0.2+ of superagent.  We have fixed numerous issues with streams, form-data, attach(), filesystem errors not bubbling up (ENOENT on attach()), and all tests are now passing.  See the releases tab for more information at <https://github.com/visionmedia/superagent/releases>.
#0 34.67 npm WARN deprecated redux-devtools-extension@2.13.9: Package moved to @redux-devtools/extension.
#0 34.79 npm WARN deprecated resolve-url-loader@5.0.0-beta.1: version 5 is now released
#0 35.03 npm WARN deprecated react-scrollspy@3.4.3: No longer actively maintained. Please use @makotot/ghostui instead.
#0 37.19 npm WARN deprecated querystring@0.2.0: The querystring API is considered Legacy. new code should use the URLSearchParams API instead.
#0 54.20 npm WARN deprecated intl-messageformat-parser@1.4.0: We've written a new parser that's 6x faster and is backwards compatible. Please use @formatjs/icu-messageformat-parser
#0 59.42 npm WARN deprecated formidable@1.2.6: Please upgrade to latest, formidable@v2 or formidable@v3! Check these notes: https://bit.ly/2ZEqIau
#0 73.97 npm WARN deprecated codecov@3.8.3: https://about.codecov.io/blog/codecov-uploader-deprecation-plan/
#0 76.96 npm WARN deprecated intl-relativeformat@2.2.0: This package has been deprecated, please see migration guide at 'https://github.com/formatjs/formatjs/tree/master/packages/intl-relativeformat#migration-guide'
#0 77.41 npm WARN deprecated babel-plugin-react-intl@7.9.4: this package has been renamed to babel-plugin-formatjs
#0 77.70 npm WARN deprecated babel-eslint@10.1.0: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates.
#0 88.07 npm WARN deprecated @types/schema-utils@2.4.0: This is a stub types definition. schema-utils provides its own type definitions, so you do not need this installed.
#0 95.47 npm notice 
#0 95.47 npm notice New minor version of npm available! 8.5.0 -> 8.13.2
#0 95.47 npm notice Changelog: <https://github.com/npm/cli/releases/tag/v8.13.2>
#0 95.47 npm notice Run `npm install -g npm@8.13.2` to update!
#0 95.47 npm notice 
#0 95.48 npm ERR! code ERR_SOCKET_TIMEOUT
#0 95.48 npm ERR! network Socket timeout
#0 95.48 npm ERR! network This is a problem related to network connectivity.
#0 95.48 npm ERR! network In most cases you are behind a proxy or have bad network settings.
#0 95.49 npm ERR! network 
#0 95.49 npm ERR! network If you are behind a proxy, please make sure that the
#0 95.49 npm ERR! network 'proxy' config is set properly.  See: 'npm help config'
#0 95.51 
#0 95.51 npm ERR! A complete log of this run can be found in:
#0 95.51 npm ERR!     /root/.npm/_logs/2022-07-11T13_42_33_237Z-debug-0.log
------
failed to solve: executor failed running [/bin/sh -c npm clean-install --no-audit --no-fund --registry=$NPM_REGISTRY   && rm -rf ~/.npm]: exit code: 1
Error: Command failed with status 17: docker compose -f /home/hussam/.local/share/tutor/env/local/docker-compose.yml -f /home/hussam/.local/share/tutor/env/local/docker-compose.prod.yml -f /home/hussam/.local/share/tutor/env/local/docker-compose.tmp.yml --project-name tutor_local up --remove-orphans --build -d

I also tried performing the same command on an ubuntu 20.04 machine and got the same error
Any help would be appreciated! Thanks.

@sooma
I am sharing you step by step documentation for Ubuntu 20.04

For Production
Create a non root user

sudo adduser **username**

sudo usermod -aG sudo **username**

then login into username user

su - **username**

sudo apt update

then install docker and compose

sudo apt-get install docker docker-compose -y

then create a docker group

sudo usermod -aG docker **username**

enable docker at startup
sudo systemctl enable docker

then install python
sudo apt install python3 python3-pip libyaml-dev -y

then install tutor
pip install "tutor[full]"

then resolve pyyaml version error

pip install PyYAML==5.4.1

pip install --upgrade "tutor[full]"

then add path of tutor in environment file

sudo nano /etc/environment

in the last add
:/home/**username**/.local/bin

sudo reboot
login in as username and then run
tutor local quickstart # for local installations