Tutor MFE: Custom translation does not work for Vietnamese

I tried to add a custom translation for Vietnamese, I added vi.json as the guide mentioned and rebuilt the mfe image but it didn’t work.
I added fr.json but with some changes to test and it worked.
It is because “vi” is not supported? If it’s not, then are there ways to workaround it?.
Thanks!

I think there is no easy around this, you might need first to fork frontend-platform and then forks all of your mfes[1] to point them to use your version of frontend-platform.

Intrestingly enough while looking at frontend-platform code, I found that there is an PR open to Vietnamese in frontend platform feat/ add Vietnamese support language by DAN3002 · Pull Request #344 · openedx/frontend-platform · GitHub. Note: I haven’t tested the PR and I am not sure if using PR patch shall make the mfe pick up your vi.json but its nonehteless might be very useful for you.


  1. You might be able to do it without forking if you used tutor-mfe patches, but I am not entrily sure. ↩︎

1 Like

Thank you, I got the idea now.