Tutor with maple.3 development environment queries

@uetuluk I have some queries related to the configuration:

  • How can I add a specific command in Dockerfile inside tutor , As I am using some submodules which are coming from my private directory. What I am doing currently I am adding “RUN git submodule init” and “RUN git submodule update” after the edx-platform clone but as soon as I run quickstart the Dockerfile update and sets to default can you provide me solution to make Dockerfile customized.

  • After setting all the details and running containers( running forked edx-platform), I was able login into lms but when I go to studio I am getting an error " ‘staticfiles’ is not a registered tag library." I tried setting in TEMPLATES in common.py with :
    " ‘libraries’: {
    ‘staticfiles’: ‘django.templatetags.static’,
    }, "
    but the issue remains.

  • I am also getting a specific type of issue for running the ecommerce - payment container only :
    No local module configuration file found. This is fine.
    payment_1 | [webpack-cli] Failed to load ‘/openedx/app/webpack.dev.config.js’ config
    payment_1 | [webpack-cli] TypeError: merge is not a function

You need to use the plugins to make changes that will persist. Here is the guide for creating a plugin: Plugins — Tutor documentation. Check this file for a list of patches you can use: tutor/patches.rst at master · overhangio/tutor · GitHub

This might be an issue with your changes, check if you used the wrong variable somewhere.

I cannot help you with e-commerce since we do not have paid courses.

@uetuluk Thank you for the solutions you have provided , I have resolved my Dockerfile and staticfiles issue.

I am currently facing a discovery setup issue :

  • I have installed ecommerce plugin which provided three plugins with it ecommerce,discovery and mfe.
  • Saved the config file then ran quickstart to setup ecommerce but ecommerce has some dependency on discovery.
  • So After the migration steps discovery gives an error where it is trying to connect to a disovery api but is unable to connect:
  • The error is → HTTPConnectionPool(host=‘local.overhang.io’, port=80): Max retries exceeded and One or more of the data loaders above failed.
  • I have checked all the details present in Oauth2 table with discovery-sso settings and they are all set with correct details.

If you have faced any issue related to this or have anything relevant to this issue please provide the help.