Unable to connect to docker-compose

Hi, I am new to Docker and Tutor, and backend management in general. I am on Windows 11.

I am getting an error on the command line to do with docker-compose, I think it is having problems connecting to it. It comes up when I try to quickstart tutor, update the images or create a new backend user.
I am confused as to what I should do. Any help would be great, thanks.

The error:

Error: Command failed with status 1: docker-compose -f C:\Users\Niall Tuohy\AppData\Local\tutor\tutor\env\local\docker-compose.yml -f C:\Users\Niall Tuohy\AppData\Local\tutor\tutor\env\local\docker-compose.prod.yml -f C:\Users\Niall Tuohy\AppData\Local\tutor\tutor\env\local\docker-compose.tmp.yml --project-name tutor_local -f C:\Users\Niall Tuohy\AppData\Local\tutor\tutor\env\local\docker-compose.jobs.yml -f C:\Users\Niall Tuohy\AppData\Local\tutor\tutor\env\local\docker-compose.jobs.tmp.yml run --rm lms-job sh -e -c
echo "Loading settings $DJANGO_SETTINGS_MODULE"

./manage.py lms manage_user  --superuser --staff penguin niall@gmail.com

./manage.py lms changepassword penguin

I’m installing on Ubuntu on Google cloud, but having a similar problem with docker-compose.

I googled the permission error i get, but the suggested repairs don’t fix the issue.

Here’s the error:
ERROR: .PermissionError: [Errno 13] Permission denied: ‘/home/matthew_petersen/.local/share/tutor/env/local/docker-compose.yml’

I’ve tried CH modding that file to no avail.

Suggestions?

Matthew P

1 Like

Hi @nialldev and @matthew.petersen68 , welcome to this forum. I don’t know the exact error, but If you don’t have other vital apps in docker, I would try to uninstall docker-compose and docker and install it again in a clean environment following the step by step from the documentation to have the proper permissions from docker.
Docker: Docker Engine installation overview | Docker Documentation
Docker-compose: Overview | Docker Documentation
Maybe it could be another way to do it, but I would prefer a clean and well-configured environment.

About permissions in the file docker-compose.yml, my permissions for that file are: -rw-rw-r-- (you can check it by doing ls -l in the env/local folder). You can have the same permissions running sudo chmod 664 docker-compose.yml @matthew.petersen68

I hope I have helped you :sparkles:

Thanks Maria! I did indeed un-install and re-install Docker (a different way this time), and I have been successful!

New problem: I have installed the Demo course, it appears in my course list as expected, I can enroll in the course. However, when I try to VIEW the course, I get “The page that you were looking for is not found”.

Just for context, I’m a fairly experienced edx.org user, but fairly new to installing and using Openedx.

cheers!

Matthew

1 Like

Hi @mafermazu , thanks for the reply. I haven’t tried this yet but will soon turn my attention back on it and let you know how it goes!

1 Like

Well, Matthew, maybe you can open a terminal and run docker logs -f <name_of_your_lms_container> and watch the logs you have when viewing the course; maybe that helps you to understand what happened inside.