Unable to run tasks to update insights


I am trying to run some of this tasks in an analytics instance https://edx-analytics-pipeline-reference.readthedocs.io/en/latest/running_tasks.html#enrollment but I always get the following error:
MissingParameterException: TASK[.....]: requires the 'source' parameter to be set

I was able to run ImportEnrollmentsIntoMysql once (the final lines of the log are attached in a file), with the following parameters:
remote-task --host localhost --user hadoop --remote-name analyticstack --skip-setup --wait ImportEnrollmentsIntoMysql --local-scheduler --interval 2019-05-20-2020-04-28 --overwrite-n-days 0 --n-reduce-tasks 8 --verbose --overwrite-hive --overwrite-mysql
but whenever I try to repeat it it brokes with the previous error

I’ve checked MySQL’s reports table and it is filled
The tracking logs are in /edx/var/log/tracking/and they are owned by hadoop

Thanks for any help

ImportEnrollmentsIntoMysql-log.rtf (1.3 KB)

Hello @Yago
Can you please share detailed logs of error?

Hi @anjali.

First of all thanks for your help!

I have ran the command as hadoop and setting the --user to hadoop, as root with root as --user, and as root with --ubuntu. I’ve added 3 different logs, one for each configuration.

There is also the log of CourseEnrollmentEventsTask, but the error is pretty the same


hadoop_ImportEnrollMentsIntoMysql_20200506.rtf (15.3 KB)
root_ImportEnrollmentsIntoMysql_20200506.rtf (15.2 KB)
ubuntu_ImpotEnrollmentsIntoMysql_20200506.rtf (2.7 KB)
root_CourseEnrollmentEventsTask_20200506.rtf (14.9 KB)

Though I am not an expert in insights but as per my knowledge you have to run the task as a root user only.

And run the task from edx-analytics-pipeline directory.

Thank you very much Anjali for your quick response, but no advance changing the user to root and launching the tasks from edx-analytics-pipeline directory


Finally I managed to run the tasks.

I needed to add an override.cfg file in my analytics repo location (in my case /var/lib/analytics-tasks/analyticstack/repo/override.cfg).

I copied https://github.com/edx/edx-analytics-pipeline/blob/ad7b86878f61b6a381c377ecd4ed2ac446089254/config/devstack.cfg to /var/lib/analytics-tasks/analyticstack/repo/override.cfg and works like a charm.

Thanks for all the help