Unknown database 'ecommerce'

So, I’ve been trying to activate the tutor ecommerce plugin.
After some several struggles and reading the documentation, I’m stuck at this problem:

the logs of migration command also throwing the same “unknown database ecommerce”

I’ve already following the installation document where I’ve used make requirements followed by make migration

and here is the error when I run the make migrate command
(I ran the command in the ecommerce container)

would you like to help me to solve this one?

The tutor-ecommerce plugin is the official way of installing ecommerce for Tutor. How did you install the ecommerce plugin?

It should have been added to your Tutor configuration with:

tutor plugins enable discovery ecommerce
tutor config save

tutor local quickstart or tutor local launch depending on the release of Tutor being used/

yep, I installed it through the tutor plugin by just enabling.
That’s why I got confused why it didn’t installed properly

Did you run tutor local launch? Did it complete successfully?

I’m running still running on the tutor dev.
Do the ecommerce for tutor dev version is not working?

Then you should have run tutor dev launch – or at least tutor dev start -d && tutor dev do init --limit=ecommerce